Login-Probleme, "webEdition kann nicht gestartet werden"

Fragen zu den Grundfunktionen der webEdition Oberfläche wie Backup, Import, ...
Fragen zu we:Tags bitte im Forum "Templates erstellen"
Creutzburg
Senior Member
Beiträge: 425
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Dresden
Kontaktdaten:

Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon Creutzburg » Mi 14. Nov 2012, 20:10

Hallo,

wir haben auf diversen WE-Installationen gefühlt ab WE 6.2.x immer mal wieder und leider nicht wirklich reproduzierbar das Problem, dass WebEdition nach dem Absenden des Login-Formulars mit einer Fehlermeldung "webEdition kann nicht gestartet werden. Es gibt Probleme mit den Session-Einstellungen in Ihrer php.ini Datei !" hängen bleibt.

Das Problem tritt wie gesagt nur sporadisch auf, dafür aber auf unterschiedlichen Rechnern/Betriebssystemen. Vor Version 6.2.1 hatten wir es definitiv nirgendwo, es tritt aber auch auf frisch installierten WE 6.3.3-Instanzen auf.

Alle diese Sites sind gehostet auf unserem DomainFactory Reseller-Server (Reseller Dedicated XL5). Der Server hat noch genügend Platz.

Hat jemand eine Idee, woran das liegen könnte bzw. wie wir das Problem eingrenzen könnten?

Danke im Voraus und Gruß,
Alex
http://www.xport.de – Internet-Agentur für Hotels
http://www.domainpreisvergleich.de – Domain-Preisvergleich inkl. Verfügbarkeits-Check – ist meine Wunschdomain noch frei, und wo registriere ich sie am günstigsten?

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1626
Registriert: Di 7. Mär 2006, 16:50
Wohnort: Wien
Kontaktdaten:

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon WBTMagnum » Mi 14. Nov 2012, 22:06

Hallo Alex,

Bei manchen unserer Installationen treten diese Probleme auch auf. Bis Dato habe ich allerdings noch kein Muster erkennen können.

Meine Erfahrungen damit:
  • An einer bestimmten Version könnte ich das Problem jetzt auch nicht festmachen.
  • Bei manchen Hostern (z.B. A1/Telekom) scheint es vermehrt zu Problemen zu kommen bei anderen garnicht (z.B. df Managed Hosting).
  • Gefühlt durfte auch der Client (ev. Proxies) eine Rolle spielen.
Irgendwie hat sich noch nicht die Gelegenheit ergeben den Problem weiter nachzugehen. Da es auch nur sporadisch auftritt, ist es auch recht schwer zu fassen. Aber wer weiß, vielleicht kommen wir der Sache ja gemeinsam auf die Schliche.


Liebe Grüße,
Sascha

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon mokraemer » Mi 14. Nov 2012, 22:38

Sind ja hier nur Fachleute:
ganz einfach. Die Meldung kommt immer dann, wenn sich zwischen Anzeige der Login-Seite und öffnen von WE die php-Session-ID geändert hat.

Eine Möglichkeit ist das die Login-Seite zu lange offen war und die Session bereits abgeräumt wurde.
webEdition-Kern-Entwickler

Creutzburg
Senior Member
Beiträge: 425
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Dresden
Kontaktdaten:

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon Creutzburg » Mi 14. Nov 2012, 23:16

Hallo Marc, hallo Sascha,

ich wäre ja froh, wenn es nur an "zu lange herumliegenden" Login-Fenstern läge. Das komische ist, dass es gefühlt eben erst seit WE 6.2.x auftritt, bei uns in der Agentur vier Leute mit WE arbeiten und allesamt dieses Phänomen seit einiger Zeit beobachten, und wir gerade eine Kundin haben, die sich beklagt, dass sie teilweise 10 mal das Login-Fenster neu laden muss, bis der Login klappt.

Ich gucke mir das bei denen morgen mal per TeamViewer an, mal gucken, ob das wirklich so ist.

Ich hatte eben noch den Verdacht, dass die Login-Seite (inkl. irgendwelcher Session-IDs als Hidden Fields) vielleicht im Browsercache liegt, aber die Header sehen nicht so aus, als ob die Seite gecached wird.

Weil es eben nur ab und an mal auftritt, haben wir es bisher auch eher ignoriert - aber wenn sich die Kunden beklagen, müssen wir uns das doch mal näher angucken.

Und wie gesagt, Server ist auch ein Managed Server von df, also eigentlich eine Null-Problem-Umgebung für WE.

Gruß,
Alex
http://www.xport.de – Internet-Agentur für Hotels
http://www.domainpreisvergleich.de – Domain-Preisvergleich inkl. Verfügbarkeits-Check – ist meine Wunschdomain noch frei, und wo registriere ich sie am günstigsten?

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon mokraemer » Mi 14. Nov 2012, 23:38

tja, aber sowas muß es sein, denn Serverseitig wird genau das verglichen!
Nämlich ob die übermittelte SessionID im Feld checkLogin mit der ID der gestarteten Session übereinstimmt.
Wenn das nicht der Fall ist, wird die Meldung ausgegeben.
webEdition-Kern-Entwickler

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1626
Registriert: Di 7. Mär 2006, 16:50
Wohnort: Wien
Kontaktdaten:

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon WBTMagnum » Do 15. Nov 2012, 01:49

Hi,

Zur Info:
Das Problem tritt bei uns auch dann auf, wenn das Login-Fenster neu aufgerufen wird und eigentlich keine frühere Session mehr vorhanden sein sollte.


LG,
Sascha

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon mokraemer » Do 15. Nov 2012, 12:23

so. ich hab einfach mal ein paar Zusatz Debug-Infos in den Dialog eingebaut.
Damit sollte man das Problem erkennen können.
webEdition-Kern-Entwickler

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1626
Registriert: Di 7. Mär 2006, 16:50
Wohnort: Wien
Kontaktdaten:

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon WBTMagnum » Do 15. Nov 2012, 12:38

Hallo Marc,

Kewl & Danke! Werde das bei nächste Gelegenheit mal auf einem System einspielen bei dem das häufiger auftritt und schauen was da angezeigt wird.

Falls jemand Cherry Picken will, hier der Link zu den relevanten Änderungen: http://webedition.svn.sourceforge.net/v ... threv=5155

LG,
Sascha

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Login-Probleme, "webEdition kann nicht gestartet werden"

Beitragvon mokraemer » Mo 19. Nov 2012, 18:07

@Alex: was kam denn raus?
webEdition-Kern-Entwickler


Zurück zu „Basisversion“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste