Seite 1 von 2

Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 12:43
von rootsdaw
Hallo,

bei mir ist bei einer Installtion von 6.3.9 (6.3.9.0, SVN-Revision: 8466) der Menüpunkt: Datei/Neu/Objekt nicht mehr da! Eine Update-Wiederholung brachte keine Änderung. Hat jemand irgendwelche Ideen, was ich tun kann?

Danke!

rootsdaw

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 12:52
von rootsdaw
Der Schnellzugriff "Neues Objekt" übers Cockpit funktioniert auch nicht: Leerer Reiter!

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 13:04
von rootsdaw
Was mir gerade auffällt, auch der Menüpunkt "Datei/Neu/Grafik" ist weg!
meinMenue.jpg
meinMenue.jpg (55.26 KiB) 3118 mal betrachtet

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 13:43
von WBTMagnum
Hallo rootsdaw,

Mit welchem User loggst du dich denn ein? Ist das ein Admin User oder ein Redakteur?

Prüfe doch mal die Zugriffsberechtigungen in der Benutzerverwaltung. Da hat sich mit dem Release 6.3.9 doch einiges geändert.

HTH,
Sascha

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 14:16
von rootsdaw
... mit Adminrechten!

Auch ein zusätzliches Anwählen aller Rechte und eine neuer LogIn hat leider nichts geändert.

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 14:24
von rootsdaw
... auch ein neuer Nutzer mit aller Rechten oder mit Adminrechten hat das gleiche reduzierte Menü!

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 14:53
von WBTMagnum
Hallo rootsdaw,

Ich kann das Verhalten bei uns nicht nachvollziehen. Sowohl für Redakteur als auch für den Admin werden die Menüpunkte angezeigt.

Ein paar Fragen:
  • Finden sich den den Logs Fehlermeldungen?
  • Wann genau ist der Menüpunkt verschwunden? Nach einem Update?
  • Welche PHP Version läuft dort?
  • Tritt das Problem in allen Browsern auf?

Liebe Grüße,
Sascha

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 15:36
von rootsdaw
Hallo Sascha,

seit wann das so ist, weiß ich leider nicht, aufgefallen ist mir das erst heute, das Update ist schon ein paar Monate alt.
Keine Fehlermeldungen und in allen Browsern das gleiche Verhalten.

PHP-Version ist die veraltete 5.2.17
Ich werde mal auf 5.4 umstellen, mal sehen, was das ändert.

Ciao

Michael

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 30. Dez 2014, 16:33
von rootsdaw
... die neue PHP-Version 5.4.35 hat leider nichts geändert.

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Fr 2. Jan 2015, 18:47
von mokraemer
Ich würde mal eine Updatewiederholung laufen lassen und mal unter Sprache bei der Install schauen, ob da evtl. noch eine alte (UTF-8) Sprache o.ä. drin hängt.
Bei den Objekten könnte man glauben, das Modul wäre deaktiviert, dann wäre aber der Punkt unveröffentlichte Objekte auch weg. Zur Sicherheit sollte man das aber auch mal kontrollieren.
Hast du denn Klassen angelegt?

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Mo 5. Jan 2015, 10:47
von rootsdaw
Also die Updatewiederholung habe ich schon mehrfach gemacht, aber was heißt: "mal unter Sprache bei der Install schauen,ob da evtl. noch eine alte (UTF-8) Sprache o.ä. drin hängt."?

Ich habe die Sprache des Backends gewechselt, das gleiche Problem.
Klassen sind angelegt.
Modul ist aktiviert. Ich habe auch mal alle Module aktiviert, keine Änderung.
Objekte kann ich bearbeiten und speichern, löschen und verschieben, aber eben keine neuen anlegn. ;-(

Vor dem letzten Update, hat auch noch alles wie gewohnt funktioniert ...

Ratlose Grüße

Michael

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Mo 5. Jan 2015, 12:39
von mokraemer
kannst du dir mal einen neuen Admin User anlegen und es damit noch mal testen?
Die Menüpunkte werden ausschließlich aufgrund von Berechtigungen eingeblendet.
Wenn das geht, entfern doch mal bei dem alten User alle Berechtigungen (Knopf unten) und setze nur Admin User, daß sollte eh ausreichen.

Ist der Admin innerhalb einer Gruppe, sodaß hier bei der Vererbung der Berechtigungen ggfs. etwas schief laufen könnte?

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Mo 5. Jan 2015, 12:59
von rootsdaw
... leider kein Erfolg!

Ich habe einen neuen Adminuser ohne Gruppenzugehörigkeit erstellt: keine Änderung.
Ich habe dem bestehenden Admin alle Rechte genommen und wieder neu zugewiesen: kein Erfolg.

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Di 6. Jan 2015, 10:40
von rootsdaw
... ich habe versucht ein Backup (1.3 GB) in eine neue Installation einzuspielen. Anfangs gab es alle Menüpunkte, um Objekte zu erstellen, nach dem Wiederherstellen (das auch nach 18 Stunden nicht ganz geklappt hat), waren die Menüpunkte wieder weg. Die Objekte und Klassen waren allerdings auch (noch) nicht wiederhergestellt.

Re: Menüpunkt verschwunden: Datei/Neu/Objekt

Verfasst: Do 8. Jan 2015, 10:05
von rootsdaw
Danke Dir, aber ich bin nicht weiter gekommen.
mokraemer hat geschrieben: Die Menüpunkte werden ausschließlich aufgrund von Berechtigungen eingeblendet.
... wenn ich aber in der usertabelle von einer funktionierenden Installation, die Berechtigungen übertrage, ändert sich leider auch nichts: Der Menüßunkt bleibt verschwunden!

Bei dem Menüpunkt werden ja die anglegten Klassen ausgelesen und angeboten: Wo geschieht das? Könnte da was schief laufen?

fragt der

Michael