Apache meldet 403 - Sicherheitsbedenken

Fragen zu den Grundfunktionen der webEdition Oberfläche wie Backup, Import, ...
Fragen zu we:Tags bitte im Forum "Templates erstellen"
Benutzeravatar
JuergenEbbing
webEdition Partner
webEdition Partner
Beiträge: 210
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Ramsdorf
Kontaktdaten:

Apache meldet 403 - Sicherheitsbedenken

Beitragvon JuergenEbbing » Di 3. Dez 2019, 19:30

Ich kann bei einer 7.0.3 Installation keine CSS Dateien bearbeiten. Sobald ich diese Daten anklicke werde ich aus dem System geworden und meine IP-Adresse vom Server geblockt. Diese Fehlermeldung wird unter anderem im Server-Log gelistet:

Code: Alles auswählen

[client 185.22.142.110] ModSecurity: Access denied with code 403 (phase 2). Pattern match "image\\\\/svg\\\\+xml|text\\\\/(?:css|html|(?:x-)?(?:(?:ecma|java|vb)script|scriptlet)).|.application\\\\/x-shockwave-flash" at REQUEST_URI. [file "/etc/apache2/modsecurity.d/rules/comodo/07_XSS_XSS.conf"] [line "69"] [id "212740"] [rev "5"] [msg "COMODO WAF: XSS Attack Detected||www.axionovo.de|F|2"] [data "Matched Data: text/css& found within REQUEST_URI: /webedition/we_cmd.php?we_cmd[0]=edit_document&we_cmd[1]=tblfile&we_cmd[2]=147&we_cmd[3]=text/css&frameid=multieditframe_4"] [severity "CRITICAL"] [tag "CWAF"] [tag "XSS"] [hostname "www.axionovo.de"] [uri "/webEdition/we_cmd.php"] [unique_id "XeaVgNRkJeoAABJHpvIAAAAC"], referer: https://www.axionovo.de/webEdition/webEdition.php?h=%27+ah+%27&w=%27+aw,%20%2733642be6de1f920ee1a147b6f0724dbd
Der Hoster sagt mir - da macht Ihr System wohl Sachen, die nicht erlaubt sind. Seltsamerweise konnte ich aber genau mit dieser Installation von einigen Wochen noch arbeiten. Ich vermute ja ehr eine Serverumstellung, die jetzt Probleme macht. Neue Seiten kann ich nach wie vor anlegen. Das ist doch sehr seltsam.

Kann jemand mit der Fehlermeldung etwas anfangen? Ich habe jetzt etwas Angst ein Update zu starten, wer weiß an welcher Stelle das abbrechen wird. Das wäre ja auch gefährlich, wenn das mittendrin beendet wird.
------------
da bin ich ja mal gespannt,
ob ich neugierig bin
------------

mokraemer
Senior Member
Beiträge: 2924
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Apache meldet 403 - Sicherheitsbedenken

Beitragvon mokraemer » Mi 4. Dez 2019, 13:33

Hallo Jürgen,
ihr habt beide Recht. Wenn du bisher mit dem Server ohne Probleme arbeiten konntest und jetzt der Fehler kommt, dann hat sich sicherlich etwas geändert. Ich vermute eben, das der Provider mod_security aktiviert hat oder die Regeln verschärft hat - das jedoch ohne vorher zu prüfen ob er das darf/sollte.
Grundsätzlich ist ein CMS in dem man HTML, CSS und JS bearbeiten kann etwas wie eine Codeinjection. Du schreibst halt den Kode bewußt und lädst ihn hoch - der Server kann ansich nicht entscheiden ob das nun von dir oder über eine Codeinjection geschehen ist. Auf dem Verzeichnis /webEdition sollte eine solche Prüfung nicht stattfinden - oder auf einer Wartungsdomain deaktiviert werden.

Im Speziellen hat hier mod-security angeschlagen, weil in der Request-URL "text/css" auftaucht - also der Datentyp der erstellt/bearbeitet werden soll. Mit der Regel wie sie hier aktiv ist, würde ein Formular bei dem Inhaltstypen (text/css, text/js, image/svg+xml, ...) eingetragen sind, auch nicht ankommen. Die Regel ist ein wenig sehr allgemein.
webEdition-Kern-Entwickler

Benutzeravatar
JuergenEbbing
webEdition Partner
webEdition Partner
Beiträge: 210
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Ramsdorf
Kontaktdaten:

Re: Apache meldet 403 - Sicherheitsbedenken

Beitragvon JuergenEbbing » Mi 4. Dez 2019, 19:39

Danke Marc!
Das klingt für mich alles absolut nachvollziehbar. Ich hätte jetzt nicht gedacht, dass der Admin die Regeln für eine bestimmte Domain oder Verzeichnis abschalten kann. Aber das werde ich jetzt mal anfragen.
Danke für Deine Hilfe!!!
------------
da bin ich ja mal gespannt,
ob ich neugierig bin
------------


Zurück zu „Basisversion“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste