Seite 1 von 1

webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 11:00
von MaGu
Hallo zusammen,
ich habe für eine Kundin eine Website mit webEdition erstellt und im März 2019 upgedated von 6.3.8. auf 7.0.4.
Vorgestern wollte ich eine Änderung an der Website vornehmen und habe festgestellt, dass alle Backendseiten sehr langsam laden. Pro Klick muss man mindestens eine Minute warten oder er bricht mit Internal Server Error 500 ab. Alle Frontendseiten laden ganz normal in ein paar milisec.
Das Fehler Protokoll zeigt nicht Auffälliges.
Der Server Error Log sagt: 07.01.2020 15:27:42 ********* [client **.***.***.**] FastCGI: "/.../htdocs/webEdition/rpc.php" aborted: no response after 123 sec (idle timeout 120 sec)

Der Strato Support sagte mir, er könne nicht helfen, da er sich nicht mit webEdition auskennt.
Im Installations Protokoll gab es anscheinend einen Fehler. Hat es damit zu tun?

Hoster: Strato
PHP Version: 7.2.25
PHP Boost (FastCGI ?): aktiviert
MySQL: 5.6.42
webEdtion: 7.0.4

Hat jemand eine Idee woran es liegt?

Danke vorab.

Re: webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 12:18
von mokraemer
Da im Protokoll von Strato keine Parameter mit ausgegeben werden, müßte man sich mal mit einem Debugger (Browser Werkzeuge) reinhängen um zu schauen welche Parameter das Script bekommt - rpc.php ist ein zentraler Einsprungspunkt. Dann weiß man zumindest mal in welchem Bereich etwas passiert.
Ist etwas schwer von außen zu beantworten - kann bspw. ein fehlender DB Index sein, sodaß die DB ewig braucht um die Abfrage zu beantworten, wodurch dann das Skript abgebrochen wird.
Du könntest eine Updatewiederholung der 7.0.4 probieren um evtl. die DB-Tabelle zu korrigieren, oder natürlich auch auf eine neuere Version wechseln... Auch wenn mir bisher nichts bekannt ist, wurde WE 7.0.4 nicht mit PHP 7.2 getestet - könnte sicherlich auch hier ein Problem sein.

Re: webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 12:18
von WBTMagnum
Hallo MaGu,
  • Gibt es Auffälligkeiten in der Systeminfo von webEdition?
  • Gibt es Fehler in der Console des Browser?
  • Ist die Versionierung in dem Projekt aktiviert?
  • Kann es sein, dass die Error Tabelle voll ist? Wie viele Fehler sind denn da schon drinnen und wie viele kommen im Schnitt hinzu?
  • Hast du im Backend ev. umfangreiche Abfragen laufen (z.B. listviews)?
  • Nutzt das Projekt Hooks für Updates?

Bzgl. dem Install Problem:
Ich vermute, Marc würde hier eine Update Wiederholung empfehlen. (^^)


HTH,
Sascha

Re: webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 12:55
von MaGu
mokraemer hat geschrieben:
Do 9. Jan 2020, 12:18
Da im Protokoll von Strato keine Parameter mit ausgegeben werden, müßte man sich mal mit einem Debugger (Browser Werkzeuge) reinhängen um zu schauen welche Parameter das Script bekommt - rpc.php ist ein zentraler Einsprungspunkt. Dann weiß man zumindest mal in welchem Bereich etwas passiert.
Ist etwas schwer von außen zu beantworten - kann bspw. ein fehlender DB Index sein, sodaß die DB ewig braucht um die Abfrage zu beantworten, wodurch dann das Skript abgebrochen wird.
Du könntest eine Updatewiederholung der 7.0.4 probieren um evtl. die DB-Tabelle zu korrigieren, oder natürlich auch auf eine neuere Version wechseln... Auch wenn mir bisher nichts bekannt ist, wurde WE 7.0.4 nicht mit PHP 7.2 getestet - könnte sicherlich auch hier ein Problem sein.
Okay. Ja es ist wirklich schwer herauszufinden.
Im Cockpit werden auch die webEdition News nicht angezeigt. Das ist wahrscheinlich dieser rpc.php Aufruf. Der braucht mindestens eine Minute bis eine Antwort als JSON vom Server kommt.
Ein Update machen ist schwierig, wenn alles so langsam ist. Nicht, dass es die Webseite zerschießt. Ich muss erstmal testen, ob ich ein Backup erstellen kann. Wenn das nicht geht, müsste ich alles manuell sichern (DB + FTP) und WE neu installieren.
Der Verbindungstest zum Update Server brachte auch den Fehler "Es konnte keine Verbindung ... aufgebaut werden."
Bei Strato gibt es in dem Paket nur noch PHP 7.2. oder höher. Welche WE Version läuft denn mit 7.2? Die Aktuelle?

Re: webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 13:06
von MaGu
WBTMagnum hat geschrieben:
Do 9. Jan 2020, 12:18
Hallo MaGu,
  • Gibt es Auffälligkeiten in der Systeminfo von webEdition?
  • Gibt es Fehler in der Console des Browser?
  • Ist die Versionierung in dem Projekt aktiviert?
  • Kann es sein, dass die Error Tabelle voll ist? Wie viele Fehler sind denn da schon drinnen und wie viele kommen im Schnitt hinzu?
  • Hast du im Backend ev. umfangreiche Abfragen laufen (z.B. listviews)?
  • Nutzt das Projekt Hooks für Updates?

Bzgl. dem Install Problem:
Ich vermute, Marc würde hier eine Update Wiederholung empfehlen. (^^)


HTH,
Sascha
-Die Systeminfo zeigt nichts Auffälliges. Siehe anbei.
-Keine Fehler in der Browserkonsole, nur lange Ladezeiten.
-Versionierung ist aktiviert.
-Die Error Log Tabelle hat gerade mal 1611 Einträge. Letzter Eintrag: Declaration of we_webEditionDocument::insertAtIndex(?array $only = NULL, array $fieldTypes = Array) should be compatible with we_textContentDocument::insertAtIndex(?array $only = NULL, ?array $fieldTypes = NULL)
-Ne, keine listviews. Es ist eigentlich reines HTML (TMPL + PHP Seiten)
-Nein, es gibt keine Hooks.

Um klarzustellen: Ich spreche ja davon, dass selbst das Aufrufen der Systeminfo, des Protokolls oder der Einstellungen minimum eine Minute brauchen bis sie angezeigt werden.
Sehr seltsam...

Re: webEdition Backend lädt langsam

Verfasst: Do 9. Jan 2020, 15:22
von adrian
Wir haben das Problem auch bei einem Kunden (im Dezember entdeckt) der noch bei Strato liegt.
Ich denk die haben irgend was angepasst. Wir haben im September in der Installation recht intensiv wegen ein Relaunch gearbeitet, da lief alles normal und schnell. Im Dezember sollte dann eine kleine Textänderung gemacht werden und es ging nichts mehr. Alles lädt komplett träge und bricht irgendwann mit Timeout ab. Änderungen an we oder den Einstellung im Strato Kundenbereich (PHP Version, etc.) wurden nicht gemacht.

Auf Nachfrage beim Strato Support kam die info, dass es an der Website liegen müsste. :lol:
Wir könne den Kunden hoffentlich bald zu nem neuen Provider umziehen.

Re: webEdition Backend lädt langsam

Verfasst: Fr 10. Jan 2020, 01:47
von mokraemer
WE 7 wirft sicherlich ein paar Warnungen wg. "function should be compatible"... wenn das viele sind, dann dauert das loggen davon auch etwas. Kenne das aber nur dann wenn bei einem Aufruf ca. >1.000 Einträge generiert werden (was in einer Schleife mal passieren kann).
Grundsätzlich sollte WE schon auch bei Strato laufen.
Vielleicht kannst du auf dem Strato account eine Subdomain mal mit einer neuen WE 8.1 Install machen und schauen ob das "normal" läuft. Wenn ja alles langsam ist, kann es ja nicht mit den Daten aus der anderen Install zusammenhängen.

Die Wartezeit ist eben der Timeout von Strato, bis sie das Skript abbrechen. Du kannst die Skriptlaufzeit ja mal auf 20 Sekunden einstellen, dann sollte man wenigstens mal irgendwas machen können. Nur sicherlich ist das keine Dauerlösung, denn es muß ja auch einen Grund geben, wo das Skript hängen bleibt.

Re: webEdition Backend lädt langsam

Verfasst: Mo 27. Jan 2020, 17:49
von mokraemer
Falls das Problem noch nicht gelöst wurde, bitte mal probieren in den Einstellungen das WE-Sessionmanagement zu aktivieren. Wenn ich das richtig sehe, dann hat Strato da einen Bug in der PHP-Config, weshalb das php-eigene Sessionmanagement nicht funktioniert!

Re: webEdition Backend lädt langsam

Verfasst: Di 28. Jan 2020, 09:39
von MaGu
Hi,
sorry, seit ca. einer Woche funktioniert alles wieder ohne, dass ich etwas gemacht habe.
Wahrscheinlich lag es an Strato -.-
Danke für eure Tipps.