Installation funktioniert nicht

Fragen und Infos zur Installation & Update von webEdition.
Benutzeravatar
christobal
Senior Member
Beiträge: 203
Registriert: Do 4. Nov 2010, 13:03
Wohnort: Reith bei Seefeld, Tirol - Österreich
Kontaktdaten:

Installation funktioniert nicht

Beitragvon christobal » Do 23. Apr 2020, 16:47

Hallo aus Tirol, jetzt hab ichs 11 mal probiert und bin jedesmal gescheitert. Die webEdition Installation auf unserem Server funktioniert nicht. Nachdem ich ein paar Hundert Installationen gemacht habe, bin ichs eigtl. gewöhnt und es klappt normalerweise immer und gut. Gestern und heute leider nicht.

Ich verwende die Version 2.9.8.4 und jedesmal bei 92% hört die Installation auf. Wir nutzen einen Plesk Server mit PHP größer 7 und MySQL 5.5, also daran hats die letzten Tage, Wochen, Monate wohl nicht gelegen.

Ist irgendwas am webEdition-Installer geändert worden oder woran könnte es liegen, ich habe alle Versionen von 6 über 7 bis 8 probiert - immer das Gleiche!

Bitte um Hilfe, Christoph
BIG Detail, Kaspar & Sigl OG
Riedgasse 8b
A-6020 Innsbruck
Tel. +43 512 346070-40
Fax +43 512 346070-20
Mobil: +43 676 3438011

christoph.kaspar@bigdetail.com
http://www.bigdetail.com

mokraemer
Senior Member
Beiträge: 3115
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Installation funktioniert nicht

Beitragvon mokraemer » Fr 24. Apr 2020, 10:55

steht was in der install.err Datei im doc-root? Da werden Fehler während der Install geloggt.

Hab gerade eine Install durchgeführt, lief komplett durch.
webEdition-Kern-Entwickler

Benutzeravatar
christobal
Senior Member
Beiträge: 203
Registriert: Do 4. Nov 2010, 13:03
Wohnort: Reith bei Seefeld, Tirol - Österreich
Kontaktdaten:

Re: Installation funktioniert nicht

Beitragvon christobal » Fr 24. Apr 2020, 11:52

Darf ich das hier posten?

Code: Alles auswählen

Array
(
    [type] => 8
    [message] => session_start(): ps_files_cleanup_dir: opendir(/var/lib/php/session) failed: Permission denied (13)
    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/setup.php
    [line] => 79
    [backtrace] => Array
        (
            [0] => Array
                (
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/setup.php
                    [line] => 79
                    [function] => session_start
                )

        )

)
Array
(
    [type] => 256
    [message] => Invalid SQL: CREATE TABLE tblPasswordReset (  ID bigint(20) unsigned NOT NULL,  UserTable enum('tblUser','tblWebUser') NOT NULL,expiresdatetime NOT NULL,token char(25) NOT NULL,password varchar(255) NOT NULL default '',loginPage int(11) unsigned NOT NULL,  PRIMARY KEY (ID,UserTable)) ENGINE=MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci (1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'NOT NULL,token char(25) NOT NULL,password varchar(255) NOT NULL default '',login' at line 1)
    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
    [line] => 239
    [backtrace] => Array
        (
            [0] => Array
                (
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
                    [line] => 239
                    [function] => trigger_error
                )

            [2] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
                    [line] => 231
                    [function] => haltmsg
                    [class] => le_MySQL
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
                    [line] => 125
                    [function] => halt
                    [class] => le_MySQL
                    [type] => ->
                )

            [4] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateFunctions.class.php
                    [line] => 674
                    [function] => query
                    [class] => le_MySQL
                    [type] => ->
                )

            [5] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateFunctions.class.php
                    [line] => 615
                    [function] => executeUpdateQuery
                    [class] => liveUpdateFunctions
                    [type] => ->
                )

            [6] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
                    [line] => 160
                    [function] => executeQueriesInFiles
                    [class] => liveUpdateFunctions
                    [type] => ->
                )

            [7] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
                    [line] => 352
                    [function] => dBUpdate
                    [class] => liveUpdateResponse
                    [type] => ->
                )

            [8] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/leTemplate.class.php
                    [line] => 84
                    [function] => getOutput
                    [class] => liveUpdateResponse
                    [type] => ->
                )

            [9] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 322
                    [function] => getOutput
                    [class] => leTemplate
                    [type] => ->
                )

            [10] => Array
                (
                    [file] => /var/www/vhosts/pfarre-hall.at/httpdocs/OnlineInstaller/setup.php
                    [line] => 200
                    [function] => executeStep
                    [class] => leOnlineInstaller
                    [type] => ->
                )

        )

)
BIG Detail, Kaspar & Sigl OG
Riedgasse 8b
A-6020 Innsbruck
Tel. +43 512 346070-40
Fax +43 512 346070-20
Mobil: +43 676 3438011

christoph.kaspar@bigdetail.com
http://www.bigdetail.com

Benutzeravatar
christobal
Senior Member
Beiträge: 203
Registriert: Do 4. Nov 2010, 13:03
Wohnort: Reith bei Seefeld, Tirol - Österreich
Kontaktdaten:

Re: Installation funktioniert nicht

Beitragvon christobal » Fr 24. Apr 2020, 12:09

Jetzt hab ich Ahlberg versucht, zu installieren, hat geklappt.
webEdition 6.4.5 hat gestern nicht funktioniert.
Ich schau mal, ob sich das Backup von einer 6.4.4 Version wiederherstellen lässt....
BIG Detail, Kaspar & Sigl OG
Riedgasse 8b
A-6020 Innsbruck
Tel. +43 512 346070-40
Fax +43 512 346070-20
Mobil: +43 676 3438011

christoph.kaspar@bigdetail.com
http://www.bigdetail.com

DC
Junior Member
Beiträge: 12
Registriert: Do 1. Jan 1970, 02:00
Kontaktdaten:

Re: Installation funktioniert nicht

Beitragvon DC » Di 30. Jun 2020, 14:58

Habe das selbe Problem. Wollte ein Update von Version 8.1.1 auf 9.01 erstellen.

Bei der Einrichtung der Datenbank ist das System hängen geblieben. Dabei wurden Backups im webEdition-Verzeichnis gelöscht. Zum Glück habe ich es noch einmal lokal auf meinem PC gespeichert.

Habe den Installer für die Version 8.1.1. und 9.01 ausprobiert. Beide bleiben bei der Einrichtung der Datenbank hängen.

Fehlermeldung:
Array
(
[type] => 256
[message] => Invalid SQL: CREATE TABLE tblCaptcha (`IP` BINARY(16) NOT NULL default '',`agent` BINARY(16) NOT NULL,`typ` enum('captcha','token','totp') NOT NULL default 'captcha',`code` BINARY(32) NOT NULL default '',`valid` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,PRIMARY KEY (`IP`,`typ`,`code`),KEY `valid`(`valid`)) ROW_FORMAT=FIXED ENGINE=MyISAM CHARACTER SET utf8 COLLATE utf8_general_ci (1050: Table 'tblCaptcha' already exists)
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
[line] => 239
[backtrace] => Array
(
[0] => Array
(
[function] => liveUpdateErrorHandler
)

[1] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
[line] => 239
[function] => trigger_error
)

[2] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
[line] => 231
[function] => haltmsg
[class] => le_MySQL
[type] => ->
)

[3] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/le_MySQL.class.php
[line] => 125
[function] => halt
[class] => le_MySQL
[type] => ->
)

[4] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateFunctions.class.php
[line] => 674
[function] => query
[class] => le_MySQL
[type] => ->
)

[5] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateFunctions.class.php
[line] => 615
[function] => executeUpdateQuery
[class] => liveUpdateFunctions
[type] => ->
)

[6] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
[line] => 160
[function] => executeQueriesInFiles
[class] => liveUpdateFunctions
[type] => ->
)

[7] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
[line] => 352
[function] => dBUpdate
[class] => liveUpdateResponse
[type] => ->
)

[8] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/leTemplate.class.php
[line] => 84
[function] => getOutput
[class] => liveUpdateResponse
[type] => ->
)

[9] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
[line] => 322
[function] => getOutput
[class] => leTemplate
[type] => ->
)

[10] => Array
(
[file] => /var/www/clients/client15/web104/web/OnlineInstaller/setup.php
[line] => 200
[function] => executeStep
[class] => leOnlineInstaller
[type] => ->
)

)

)

mokraemer
Senior Member
Beiträge: 3115
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Installation funktioniert nicht

Beitragvon mokraemer » Di 30. Jun 2020, 15:30

siehe:
https://www.webedition.org/de/dokumenta ... zungen.php

Deine MySQL Version ist zu alt.
Backups werden nicht gelöscht, sondern verschoben. Siehe
https://www.webedition.org/de/dokumenta ... 0-barrhorn
webEdition-Kern-Entwickler


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: WBTMagnum und 3 Gäste