Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechtigung

Fragen und Infos zur Installation & Update von webEdition.
Creutzburg
Senior Member
Beiträge: 425
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Dresden
Kontaktdaten:

Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechtigung

Beitragvon Creutzburg » Fr 13. Dez 2013, 12:33

Hallo,

eben haben wir eine WE-Seite von 6.3.6 auf 6.3.8 upgedatet, und nach erfolgreichem Update erscheint nach dem Login die Fehlermeldung "Fehler: Sie haben keine Berechtigung". Die WE-Oberfläche erscheint zwar, es ist allerdings keinerlei Aktion möglich (auch kein Rebuild).

Hat jemand eine Idee, was hier schief gelaufen sein könnte?

Dank & Gruß,
Alex
http://www.xport.de – Internet-Agentur für Hotels
http://www.domainpreisvergleich.de – Domain-Preisvergleich inkl. Verfügbarkeits-Check – ist meine Wunschdomain noch frei, und wo registriere ich sie am günstigsten?

e_herrmann
Senior Member
Beiträge: 1281
Registriert: Do 22. Mai 2003, 23:25

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon e_herrmann » Fr 13. Dez 2013, 13:11

Hi,
ich habe den Bug hier schon gemeldet:
http://qa.webedition.org/tracker/view.php?id=8289

Poste dort doch mal, ob das bei euch ähnlich ist.

Grüße Elko
Elko Herrmann
komplexx | internet.fotografie
web: http://www.komplexx.de

Creutzburg
Senior Member
Beiträge: 425
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Dresden
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon Creutzburg » Fr 13. Dez 2013, 13:17

Der von Dir gepostete Bug hängt aber ja mit der Navigation zusammen, und nicht mit dem nicht möglichen Login ins WE-Backend, oder?
http://www.xport.de – Internet-Agentur für Hotels
http://www.domainpreisvergleich.de – Domain-Preisvergleich inkl. Verfügbarkeits-Check – ist meine Wunschdomain noch frei, und wo registriere ich sie am günstigsten?

e_herrmann
Senior Member
Beiträge: 1281
Registriert: Do 22. Mai 2003, 23:25

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon e_herrmann » Fr 13. Dez 2013, 13:22

Nicht nur, das war das erste was mir auffiel. Schau mal meinen heutigen Kommentar.
Ob das jetzt ein oder mehrere Bugs sind, soll Marc entscheiden.
Elko Herrmann
komplexx | internet.fotografie
web: http://www.komplexx.de

e_herrmann
Senior Member
Beiträge: 1281
Registriert: Do 22. Mai 2003, 23:25

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon e_herrmann » Fr 13. Dez 2013, 13:23

Versuch mal einen Browser-Neustart, oder Cache löschen, hilft das bei euch?
Elko Herrmann
komplexx | internet.fotografie
web: http://www.komplexx.de

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Mi 15. Okt 2014, 12:40

Hi,

hat sich hier inzwischen etwas getan? Stehe gerade vor dem selben Problem. Vor dem Update hat webEdition auf dem Server einwandfrei funktioniert. session.gc_probability steht auf 0.

Nachtrag: Der Hinweis kommt vor dem Laden des Cockpits.

Grüße,

Andreas
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

ThomasGoebe
Senior Member
Beiträge: 865
Registriert: Mo 26. Jul 2010, 23:44
Wohnort: Hannover
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon ThomasGoebe » Mi 15. Okt 2014, 16:00

Hallo Zusammen,

ich hatte das auch schon mal sporadisch. Meist hatte ich dann noch einen anderen User im System, bin in die Benutzerverwaltung gegangen und habe den fehlerhaften Benutzter neu gespeichert. Dann ging es wieder.

Wenn Du noch in die Einstellungen kommst, dann half auch, ganz simpel mit dem Benutzer die Extas > Einstellungen > Allgemein einmal neu zu speichern.

Wenn kein Zugriff mehr klappte, dann half in der DB das Benutzerpasswort zurückzusetzen.

Leider hatte ich das Problem nur ein paar Mal und konnte es nie für eine sinnvolle Fehlermeldung nachstellen. Scheint gerne bei Updates zu passieren.
Thomas Göbe
webEdition Experte aus Hannover
Autor des 1. webEdition Buch (gemeinsam mit Andreas Witt)
web: http://www.projektheimat.de

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Mi 15. Okt 2014, 17:00

... Danke, Thomas. Aber der Fall liegt hier anders. Ich kann mich ja einloggen, es wird auch der Frame geladen, aber dann beim Anzeigen des Cockpits kommt der Hinweis!
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

ThomasGoebe
Senior Member
Beiträge: 865
Registriert: Mo 26. Jul 2010, 23:44
Wohnort: Hannover
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon ThomasGoebe » Mi 15. Okt 2014, 22:53

ja, das meine ich ja. Ein neues Speichern des Users bzw. der Einstellungen hat genau dieses Problem bei mir gelöst.
Thomas Göbe
webEdition Experte aus Hannover
Autor des 1. webEdition Buch (gemeinsam mit Andreas Witt)
web: http://www.projektheimat.de

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Mi 15. Okt 2014, 23:30

... wenn diese Meldung kommt, kann man ja nichts mehr im System tun. Warum soll das erneute Speichern des Passwortes was bringen - es scheint ja korrekt zu sein. Aber ich kann das morgen gern mal versuchen ;)
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mokraemer » Do 16. Okt 2014, 00:46

@mausi: das ist das was ich dir schon mal auf deinem Server berichtet hatte, daß hier Sessions zerstört werden. Die Gründe liegen primär im Server selbst und waren nicht zu ermitteln. Mit WE 6.3.9 bringen wir eine eigene Sessionverwaltung mit,mit der dies nicht (mehr) passieren sollte.
webEdition-Kern-Entwickler

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Do 16. Okt 2014, 08:27

... habe webEdition immer geliebt, weil es auf allen mir bekannten Standard-Server Installationen lief. Meine beiden Server sind das auch. Ganz normale Debian-Kisten aus dem Regal des Hosters. Aber schon lustig - habe mich 2002 entschieden für meine eigenen Anwendungen eine eigene auf MySQL basierte Session-Verwaltung einzusetzen, weil es damals oft Probleme mit der von PHP gab. War eine richtige Entscheidung ;)

Bleibt mir jetzt wohl nichts anderes übrig zu recherchieren was ich am Server schrauben muss damit WE funktioniert ...
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Do 16. Okt 2014, 13:27

... Fehler gefunden: Es lag an register_globals=On.
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

mokraemer
Senior Member
Beiträge: 3051
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mokraemer » Do 16. Okt 2014, 22:43

ach du hast noch ein php wo das geht?
Aber ja, wenn die an sind, sind die Auswirkungen nicht immer logisch. Denn teilweise überschreiben da (auch nachträglich) deklarierte Variablen die aus der Session.
webEdition-Kern-Entwickler

Benutzeravatar
mausi
Senior Member
Beiträge: 385
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Nach Update 6.3.6>6.3.8 Fehler: Sie haben keine Berechti

Beitragvon mausi » Fr 17. Okt 2014, 08:42

... geht über Plesk. Wenn das irgendwann nicht mehr möglich sein sollte, habe ich sehr viel zu tun, da einige Anwendungen noch nicht umgestellt sind, da älter. Hoffe das wird lange noch möglich sein. Aber es gibt ja auch quick&dirty Lösungen zum Konvertieren vpn $_POST zu globalen Variabeln ...
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste