Backendlogin nach Update funktioniert nicht.

Fragen und Infos zur Installation & Update von webEdition.
dehrich
Junior Member
Beiträge: 21
Registriert: Mo 2. Dez 2013, 17:36

Backendlogin nach Update funktioniert nicht.

Beitragvon dehrich » Do 5. Okt 2017, 09:08

Hallo,

ich habe nun mehrmals versucht ein Update von Version 7.0.1. auf 7.0.4 zu machen - jedes mal mit dem Ergebnis mich nicht mehr ins Backend einloggen zu können. Das Formular wird anscheinend nicht ausgeführt, da ich immer wieder (ohne Fehlermeldung) auf die Loginseite weitergeleitet werde.

Ist dieses Problem bekannt oder gibt es sogar schon eine Lösung hierfür?

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1322
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon WBTMagnum » Do 5. Okt 2017, 14:08

Hallo dehrich,

Wenn ich dich richtig verstehe, dann bekommst du die Login-Seite korrekt angezeigt, kannst dich aber nicht am Backend. anmelden und wirst wieder auf die Login-Seite "geworfen". Korrekt?

Ein paar Fragen:
  • Welche PHP Version?
  • Finden sich Fehler im Apache Error Log?
  • Das Frontend geht?
  • Betrifft das einen Nutzer oder alle?

Ich würde mal schauen, ob du in der 7.0.1 eine Passwortrichtlinie definiert hast. Eventuell greift die jetzt und du kannst dich nicht anmelden?

HTH,
Sascha

mokraemer
Senior Member
Beiträge: 2369
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon mokraemer » Do 5. Okt 2017, 17:23

@Sascha: die Passwortrichtlinie weißt nur nach dem Login auf eine Passwortänderung hin.
@dehrich: von dem Problem habe ich bisher noch nichts gehört. Wir warten dann mal auf deine Antworten.
webEdition-Kern-Entwickler

dehrich
Junior Member
Beiträge: 21
Registriert: Mo 2. Dez 2013, 17:36

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon dehrich » Do 12. Okt 2017, 08:55

...entschuldigt die verspätete Antwort.

Genau, es wird auch keine Fehlermeldung ausgegeben. Nach dem "Einloggen" hat man praktisch wieder die selbe Ansicht wie davor.

    PHP Version: 5.6.31
    Fehler im Error-log laut Kunde nicht vorhanden
    Frontend funktioniert ohne Einschränkungen
    Es betrifft alle Backend-User

Bis jetzt hatten wir bei keinem Projekt ein Problem mit dem Update. Leider ist es so, dass wir bei diesem Kunden keinen Zugriff auf den Server haben, daher auch dort die Einstellungen nicht nachvollziehen können.

mokraemer
Senior Member
Beiträge: 2369
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon mokraemer » Do 12. Okt 2017, 10:28

Hmm, also ohne Zugriff auf den Server wird es sicherlich schwer werden das geeignet zu überprüfen bzw. den Fehler zu beheben.
Ist die WE Session-Verwaltung an, oder die von PHP?
Für mich klingt das danach, daß WE keine Session erzeugen kann und dir dann den Login-Screen erneut präsentiert.
Es kann durchaus sein, daß WE den Fehler feststellt und protokolliert, dazu müßte man in der DB mal ins Error-Log schauen. Ich hoffe das WE-Logging ist aktiviert???
webEdition-Kern-Entwickler

dehrich
Junior Member
Beiträge: 21
Registriert: Mo 2. Dez 2013, 17:36

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon dehrich » Do 12. Okt 2017, 15:06

Die Sessionverwaltung von webEdition ist nicht aktiv. In den WE-Logs war auch nichts auffällig.

mokraemer
Senior Member
Beiträge: 2369
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon mokraemer » Do 12. Okt 2017, 16:52

das ist blöd. Mit Sessionverwaltung könnte man das ggfs. einschränken.
Wenn aber nix im Fehlerlog ist und alle Fehlerarten protokolliert werden, dann können wir dir so nicht helfen.
Es gibt durchaus viele Stellen an denen es haken kann - suhosin oder sonstige Installationen auf dem Server. Es kann auch eine Einstellung in der .htaccess-Datei sein, die hier wieder einen redirect macht. Da muß man ggfs. das Logging dafür (im WebServer) ebenfalls anschalten und die Logs lesen.
Hast du einen Kundenbereich? Geht der Login da im Frontend?

Hellsehen kann ich allerdings nicht, also es gibt wirklich viele Stellen an denen das schief laufen kann und dazu auch ne Menge externer Konfigs. Generell ist mir dieses Verhalten von WE unbekannt - und dürfte vermutlich auch bei anderen Installs von Euch nicht auftreten - also muß man den Unterschied finden....
webEdition-Kern-Entwickler

dehrich
Junior Member
Beiträge: 21
Registriert: Mo 2. Dez 2013, 17:36

Re: Backendlogin nach Update funktioniert nicht.

Beitragvon dehrich » Fr 13. Okt 2017, 08:19

Danke für die Hilfe.

Das Update haben wir jetzt erstmal ausgesetzt da es momentan nicht Not tut. Allerdings gehe ich auch davon aus, dass hier ein Fehler am Server vorliegt.

Der Frontend Login hat funktioniert.

Das ist richtig, dieses Verhalten ist bei uns auch zum ersten mal aufgetreten. Der fehlende Zugriff auf den Server macht die Fehlersuche da leider nicht einfacher.


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste