Error bei OnlineInstaller / webEdition 8.0.2

Fragen und Infos zur Installation & Update von webEdition.
planb
Junior Member
Beiträge: 3
Registriert: So 27. Dez 2015, 13:32

Error bei OnlineInstaller / webEdition 8.0.2

Beitragvon planb » Do 24. Mai 2018, 00:48

Hallo habe mit dem neuen OnlineInstaller folgendes Problem. Ab dem Punkt "PHP-Version, Sessions & Cookies" geht nichts mehr weiter. Egal ob man auf "Weiter" klickt als auch wenn man die 14 Sekunden wartet die Angezeigt werden.

Hat dazu jemand eine Idee :idea:

Im "installer.error" steht folgendes:

Code: Alles auswählen

Array
(
    [type] => 8192
    [message] => The each() function is deprecated. This message will be suppressed on further calls
    [file] => /pages/52/3b/d0013920/home/htdocs/planb-kommunikation-gestaltung/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
    [line] => 261
    [backtrace] => Array
        (
            [0] => Array
                (
                    [function] => le_errorhandler
                )

            [1] => Array
                (
                    [file] => /pages/52/3b/d0013920/home/htdocs/planb-kommunikation-gestaltung/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 261
                    [function] => each
                )

            [2] => Array
                (
                    [file] => /pages/52/3b/d0013920/home/htdocs/planb-kommunikation-gestaltung/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 237
                    [function] => getNextWizardStep
                    [class] => leOnlineInstaller
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /pages/52/3b/d0013920/home/htdocs/planb-kommunikation-gestaltung/OnlineInstaller/setup.php
                    [line] => 150
                    [function] => initialize
                    [class] => leOnlineInstaller
                    [type] => ->
                )

        )

)

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1441
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Error bei OnlineInstaller / webEdition 8.0.2

Beitragvon WBTMagnum » Do 24. Mai 2018, 09:43

Hallo planb,

Der Fehlermeldung nach (sh. google), verwendest du PHP 7.2. IIRC solltest du bei mit wE8.0.x noch bei PHP 7.0 bleiben.

HTH,
Sascha

planb
Junior Member
Beiträge: 3
Registriert: So 27. Dez 2015, 13:32

Re: Error bei OnlineInstaller / webEdition 8.0.2

Beitragvon planb » Do 24. Mai 2018, 18:46

Leider funktioniert die Installation weiterhin nicht. Auf dem Server habe ich Anfang Mai noch ohne Probleme webEdition mit dem OnlineInstaller aufspielen können.

Nachdem ich PHP auf die Version 7.0 eingestellt habe, wie von dir empfohlen bricht die Intallation nach wie vor beim Punkt "PHP-Version, Sessions & Cookies" ab. Nur dieses mal bekomme ich keine "installer.error".

Die PHP-einstellung sind wie folgt bei dem Server:


PS: Bei einer manuellen Installation bekomme ich immer die Fehlermeldung, dass die Angaben zur Datenbank falsch sind (Host, Datenbankname, Benutzer, Passwort etc.) obwohl ich diese bereits mehrmals kontrolliert habe. Woran kann das liegen?
Dateianhänge
Bildschirmfoto-2018-05-24-um-18.42.00.jpg
Bildschirmfoto-2018-05-24-um-18.42.00.jpg (150.31 KiB) 160 mal betrachtet

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1441
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Error bei OnlineInstaller / webEdition 8.0.2

Beitragvon WBTMagnum » Do 24. Mai 2018, 19:59

Hallo,

Schwer zu sagen. Schau doch mal in den Fehlerlog des Apache oder lass dir die Fehler anzeigen (display_errors).

In den Systemvoraussetzungen habe ich noch folgende Hinweise gefunden:
Bei aktiviertem session.auto_start wird vom Zend Framework eine Fehlermeldung ausgegeben, da keine Zend_Session gestartet werden kann. Verschiedene Anwender berichten, dass die Einstellung zend.ze1_compatibility_mode=on zu einem Abbruch von Installation und liveUpdate führt. Eine Einstellung von zend.ze1_compatibility_mode=off (in der php.in oder per php_admin_flag löst dann das Problem. Für liveUpdate bzw. den OnlineInstaller wird entweder aktivierte allow_url_fopen on oder die PHP-Extendion curl benötigt.
HTH,
Sascha

mokraemer
Senior Member
Beiträge: 2598
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Error bei OnlineInstaller / webEdition 8.0.2

Beitragvon mokraemer » Mo 28. Mai 2018, 15:10

Wenn url_fopen deaktiviert ist, kann der Installer ja die Dateien nicht runter laden. Das dürfte sicherlich ein Problem sein, wenn die Option gesetzt ist.
webEdition-Kern-Entwickler


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste