Nach Serverumzug Verzeichnisbaum leer

Fragen und Infos zur Installation & Update von webEdition.
DieKleine
Member
Beiträge: 51
Registriert: Mo 7. Nov 2016, 18:29

Nach Serverumzug Verzeichnisbaum leer

Beitragvon DieKleine » Mo 19. Nov 2018, 18:33

Hallo,

Rahmeninformationen zuerst:
- webEdition Version 8.0.3
- PHP 7.2
- MySQL Version 5.7.24

Der Betreff sagt im Endeffekt schon fast alles aus.
D
Ich habe die Daten via FTP und DB Dump hochgeladen – dann war das Backend erst einmal komplett leer. Das Frontend lässt sich aber ohne Probleme aufrufen und sieht auch genau so aus, wie es aussehen sollte… Das Rebuild brachte keinen Erfolg.
Im Backend konnte ich keine Tabs schließen, auch der Logout-Button hat nicht funktioniert.

Die Fehlerlogs haben mir einige JS-Errors ausgeworfen – durch erneutes hochladen der JS Dateien verschwanden die Fehlermeldungen und ein paar der Template Dateien und 2 Dokumente werden im Backend angezeigt - leider allerdings nur meine Test Dokumente...
Logout funktioniert seit dem, genau so wie das schließen von Tabs.

In den Fehlerlogs steht nichts mehr.

Ich habe geprüft ob in der Datenbank alle Einträge vorhanden sind – sind sie.
Ich habe alles bis auf die we_conf.inc.php aus einer frischen Installation via FTP drüber gebügelt…
Dennoch wird die angelegte Klasse nicht angezeigt und Objekte werden nicht gefunden – diese werden auch im Frontend nicht angezeigt.

An der Datenbank scheint es nicht zu liegen – die Verbindung steht. Ich kann neue Dokumente anlegen, speichern und löschen.

Nun weiß ich leider auch nicht weiter….
Kann mir jemand sagen ob einfach nur beim Hochladen via FTP irgendwas schiefläuft, oder ob es einen anderen Grund haben kann?
Und, am wichtigsten: Wie bekomme ich das Backend wieder hin?

Vielen Dank schon mal.

LG
Anna

mokraemer
Senior Member
Beiträge: 2737
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon mokraemer » Mo 19. Nov 2018, 20:44

hast du bei der Installation einen abweichenden DocRoot eingetragen??
Wenn du das 1:1 auf einen neuen Server packst, muß das auch übereinstimmen. Für mich klingt es aktuell danach als würden Dateien nicht gefunden / ausgeliefert. Da ist es das beste mal einen Debugger mitlaufen zu lassen und zu schauen ob er über fehlenden Dateien (Http 404) motzt.
Evtl. hilft dir auch eine Updatewiederholung - die sorgt jedenfalls mal dafür das alle WE-Dateien korrekt da sind. Evtl. sind auch Verzeichnisrechte nicht korrekt.
webEdition-Kern-Entwickler

DieKleine
Member
Beiträge: 51
Registriert: Mo 7. Nov 2016, 18:29

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon DieKleine » Do 22. Nov 2018, 09:58

Hallo,

danke schon mal für die Antwort.
Ich habe mal die Punkte abgeklappert die du genannt hast. Der DocRoot stimmt - daran kann es also nicht liegen.
Die Konsole von Firefox bringt mir zwei deprecated Meldungen und folgendes:
unreachable code after return statement[Weitere Informationen] we_fileupload_imageEdit.js:869:2
unreachable code after return statement[Weitere Informationen] we_fileupload_imageEdit.js:885:2

Damit kann ich jedoch recht wenig anfangen...

Die Updatewiederholung hat nichts verändert - allso gehe ich davon aus, dass die WE-Dateien stimmen. Wie müssen die Verzeichnisrechte eingestellt sein?
Aktuell habe ich auf den Verzeichnissen die Rechte 775 und auf Dateien 644.
Wer muss als Besitzer der Dateien eingestellt sein?
Aktuell ist es so, dass der FTP User als Besitzer eingetragen ist - muss das eventuell umgestellt werden?

LG
Anna

mokraemer
Senior Member
Beiträge: 2737
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon mokraemer » Do 22. Nov 2018, 16:45

die meldungen von FF kannst du ignorieren, das ist Absicht.
Wer der User ist und wie die Zugriffsrechte sind, hängt vom Server ab.
Wie hast du denn die Datenbank eingespielt?
webEdition-Kern-Entwickler

DieKleine
Member
Beiträge: 51
Registriert: Mo 7. Nov 2016, 18:29

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon DieKleine » Fr 23. Nov 2018, 11:58

Ich habe die Datenbank via phpMyAdmin importiert.
Dabei gab es keine Fehlermeldung.

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1503
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon WBTMagnum » Fr 23. Nov 2018, 15:45

Mach sicherheitshalber noch einen Vergleich ob die wesentlichen Parameter (Tabellen, Größe, etc.) der Datenbank stimmen. Nur weil kein Fehler gekommen ist, heißt das noch lange nicht, dass der Import durchgelaufen ist. phpMyAdmin hat da so seine Tücken.

Liebe Grüße,
Sascha

DieKleine
Member
Beiträge: 51
Registriert: Mo 7. Nov 2016, 18:29

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon DieKleine » Mo 26. Nov 2018, 16:11

Danke für die Anregung.
Beide Datenbanken sind gleich. Gleiche größe, gleiche Anzahl an Einträgen, die gleichen Einträge...

Zum Test habe ich vorhin damit angefangen die Dateien via webEdition zu exportiern und auf dem neuen Server zu impriteren.
Das Funktioniert so weit, ist aber sehr Zeitaufwändig, weil es eine große Seite ist und ich auf dem neuen Server ein recht niedriges Upload Limit habe. Leider habe ich noch Probleme mit dem Menü im Frontend, aber ich hoffe dass sich das gibt, sobald ich alle Dateien importiert habe.

Jetzt mal aus Interesse:
Was ist die beste Art eine webEdition Seite um zu ziehen?
In Zukunft werde ich wohl noch öfter damit zu tun haben und möchte die einfachste, zeitsparenste Möglichkeit nutzen.

LG
Anna

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1503
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Nach Serverumzug Verzeichnisbaum leer

Beitragvon WBTMagnum » Di 27. Nov 2018, 11:17

Hallo Anna,

Wir gehen in der Regel wie folgt vor:
  1. Quellsystem: DB Dump erstellen
  2. Quellsystem: File Dump von /webEdition/site/ erstellen
  3. Dumps auf das Zielsystem kopieren
  4. Zielsystem: leere webEdition Installation vorbereiten
  5. Zielsystem: File Dump einspielen
  6. Zielsystem: DB Dump einspielen
Je ähnlicher sich Quell- und Zielsystem sind, desto höher sind die Erfolgschancen. Bei manchen Hostern sind die Setups sehr eigen. Da muss man schon mal in die eine oder andere Trickkiste greifen.

HTH,
Sascha


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste