Probleme beim Installieren

Fragen und Infos zur Installation & Update von webEdition.
Luigii
Senior Member
Beiträge: 396
Registriert: Mi 20. Jul 2005, 17:18

Probleme beim Installieren

Beitragvon Luigii » Di 18. Dez 2018, 13:13

Ich versuche gerade WE auf einem Server zu installieren. Es läuft bis zur einGabe des Logins für WE. An diser Stelle bekomme ich dann einen leeren Alert und wenn ich dann auf Weiter gehe, dann steht dort, dass ich einen Benutzernamen eingeben soll. Den hatte ich natürlich eingegeben.
error-01.jpg
error-01.jpg (57.33 KiB) 297 mal betrachtet
Im Installer.err steht dann Folgendes:

Code: Alles auswählen

Array
(
    [type] => 8192
    [message] => Non-static method liveUpdateTemplates::getHtml() should not be called statically, assuming $this from incompatible context
    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
    [line] => 102
    [backtrace] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
                    [line] => 102
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leTemplate.class.php
                    [line] => 111
                    [function] => getOutput
                    [class] => liveUpdateResponse
                    [type] => ->
                )

            [2] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 373
                    [function] => getOutput
                    [class] => leTemplate
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/setup.php
                    [line] => 208
                    [function] => executeStep
                    [class] => leOnlineInstaller
                    [type] => ->
                )

        )

)
Array
(
    [type] => 8192
    [message] => Non-static method liveUpdateTemplates::getHtmlHead() should not be called statically, assuming $this from incompatible context
    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateTemplates.class.php
    [line] => 61
    [backtrace] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateTemplates.class.php
                    [line] => 61
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
                    [line] => 102
                    [function] => getHtml
                    [class] => liveUpdateTemplates
                    [type] => ->
                )

            [2] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leTemplate.class.php
                    [line] => 111
                    [function] => getOutput
                    [class] => liveUpdateResponse
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 373
                    [function] => getOutput
                    [class] => leTemplate
                    [type] => ->
                )

            [4] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/setup.php
                    [line] => 208
                    [function] => executeStep
                    [class] => leOnlineInstaller
                    [type] => ->
                )

        )

)
Array
(
    [type] => 8192
    [message] => Non-static method liveUpdateTemplates::getContainer() should not be called statically, assuming $this from incompatible context
    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateTemplates.class.php
    [line] => 65
    [backtrace] => Array
        (
            [0] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateTemplates.class.php
                    [line] => 65
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/liveUpdateResponse.class.php
                    [line] => 102
                    [function] => getHtml
                    [class] => liveUpdateTemplates
                    [type] => ->
                )

            [2] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leTemplate.class.php
                    [line] => 111
                    [function] => getOutput
                    [class] => liveUpdateResponse
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 373
                    [function] => getOutput
                    [class] => leTemplate
                    [type] => ->
                )

            [4] => Array
                (
                    [file] => /var/www/web/OnlineInstaller/setup.php
                    [line] => 208
                    [function] => executeStep
                    [class] => leOnlineInstaller
                    [type] => ->
                )

        )

)
Hat jemand eine Idee, was da falsch läuft?
Dinge von großer Bedeutung gehe man mit Leichtigkeit an, Dinge von geringer Bedeutung mit großem Ernst.

Tomeric
Member
Beiträge: 38
Registriert: Do 7. Jan 2010, 03:31

Re: Probleme beim Installieren

Beitragvon Tomeric » Mi 19. Dez 2018, 16:19

Ja, das hatte ich auch gerade.
Ich habe deshalb die Installation mit Chrome statt Safari wiederholt, und damit klappte es.
Sieht so aus, als ob der Online-Installer nicht auf Safaris steht...

mokraemer
Senior Member
Beiträge: 2734
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Probleme beim Installieren

Beitragvon mokraemer » Mi 19. Dez 2018, 16:37

kann gut sein, da es Safari nur für Mac gibt, fehlen uns da die Testmöglichkeiten. Gab von unserer Seite aber hier keine Änderungen
webEdition-Kern-Entwickler

Luigii
Senior Member
Beiträge: 396
Registriert: Mi 20. Jul 2005, 17:18

Re: Probleme beim Installieren

Beitragvon Luigii » Mi 19. Dez 2018, 16:53

Hallo,
ich hatte es mit einem Firefox installiert. Heute geht es dann plötzlich.
Es könnte noch sein, dass es mit meiner Internetverbindung zutun hatte, ich hatte nämlich gestern immer wieder Abbrüche und ein miserables Signal. Vielleichthat das einfach die Übertragung gestört.
Dinge von großer Bedeutung gehe man mit Leichtigkeit an, Dinge von geringer Bedeutung mit großem Ernst.

mokraemer
Senior Member
Beiträge: 2734
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Probleme beim Installieren

Beitragvon mokraemer » Do 20. Dez 2018, 12:23

das ist durchaus möglich.
Wir müssen demnächst auch noch mal den Installer/Updater mit den PHP Updates und den Änderungen in WE nachziehen.
webEdition-Kern-Entwickler


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste