Update von 7.0.4 auf 8.1 Beitrag ist gelöst

Fragen und Infos zur Installation & Update von webEdition.
rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » So 3. Feb 2019, 15:22

Hallo zusammen,

ich würde eine länger nicht gewartete Seite gerne von 7.0.4 auf 8.1 updaten. Allerdings komme ich zum ersten Mal mit WebEdition in Berührung und möchte das Update deshalb nicht unvorbereitet anstoßen.
Gibt es Erfahrungswerte, mit welchen Probleme ich während und nach einem solchen Update zu rechnen habe? Hat jemand Tipps und Empfehlungen?
(Dokumentation habe ich schon gefunden und teilweise schon gelesen, allerdings ist sie an manchen Stellen etwas kryptisch ;)

Danke für Tipps und Ratschläge,
Ruby

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1529
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon WBTMagnum » Do 7. Feb 2019, 21:56

Hallo Ruby,

Erst mal ist 8.1 noch nicht offiziell veröffentlicht. An deiner Stelle würde ich auf die aktuelle 8.0.x gehen. Ob bzw. welche Probleme auftreten können, hängt stark vom Projekt, den eingesetzten Modulen und der Code-Qualität ab.

Wenn du hier das erste mal ein Update durchführst, würde ich dir empfehlen das System auf ein Testsystem zu Clonen und erst mal alles in Ruhe durchzuspielen. Wenn es sich um eine "einfache" Site handelt, wird das nicht so wild sein und du kann das Produktivsystem rasch hoch ziehen. Bei komplexeren Projekten (idR. mehrere Module, Custom Tags, Hooks, PHP Code, etc.) hast du so die Möglichkeit die notwendigen Schritte für das Update zu planen und alles vorzubereiten.

Generell finden sich in der Versionshistorie jede Menge Hinweise auf durchgeführte Änderungen. Man muss allerdings wissen ob und wie es die eigenen Projekte betrifft ;-).

HTH,
Sascha

mehrenfeld
Junior Member
Beiträge: 8
Registriert: Do 15. Nov 2012, 14:41
Wohnort: 87471 Durach
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon mehrenfeld » Di 12. Feb 2019, 15:10

ich mache gerade ein paar updates von 7 --> 8.05 und ein paar seltsame Dinge sind mir bereits aufgefallen:

- bei bestimmten benutzern wird bei den Einstellungen der Backendzeichensatz auf ISO gesetzt, was zur Folge hat, dass beim entsprechenden Benutzer keine Sonderzeichen mehr dargestellt werden.

- bei Einstellungen --> Allgeimein --> Module müssen die Kategorien gewählt werden.

ansonsten habe ich noch diverse Probleme mit Globalen Variablen und der Kalenderfunktion.

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1529
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon WBTMagnum » Di 12. Feb 2019, 22:49

mehrenfeld hat geschrieben:
Di 12. Feb 2019, 15:10
- bei bestimmten benutzern wird bei den Einstellungen der Backendzeichensatz auf ISO gesetzt, was zur Folge hat, dass beim entsprechenden Benutzer keine Sonderzeichen mehr dargestellt werden.
Das hatten wir auch schon mal. Das lag im Endeffekt daran, dass im Config File - warum auch immer - noch ISO gesetzt, aber bei den Backend Usern noch kein Zeichensatz angegeben war. Damit sind die BenutzerInnen wieder auf ISO gefahren.

mehrenfeld hat geschrieben:
Di 12. Feb 2019, 15:10
- bei Einstellungen --> Allgemein --> Module müssen die Kategorien gewählt werden.
Stimmt, ist in der Versionshistorie der 8.0 auch explizit angeführt.

Liebe Grüße,
Sascha

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » So 3. Mär 2019, 17:10

Hi,
danke für eure Antworten :)

Gibt es irgendwo eine Anleitung für die Erstellung eines Clons?

Grüße,
Ruby

Benutzeravatar
haydi
Senior Member
Beiträge: 553
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Hirschberg
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon haydi » Mo 4. Mär 2019, 11:51

Hallo Ruby,

nein, eine Anleitung für die Erstellung eines Clons gibt es meines Wissens nicht.

Du machst einfach ein webEdition Backup von der zu klonenden Website.
Dann installierst du auf der neuen Umgebung webEdition in der gleichen Version wie die von der du das Backup hast.
Nach der Installation spielst du das Backup ein. Danach Rebuild und fertig.

ciao
heidi
Heidi Wetzel
Internet-Applikationen & Webseiten-Erstellung
https://www.heidi-wetzel.de

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » Mo 4. Mär 2019, 12:15

Thx :)

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1529
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1  Beitrag ist gelöst

Beitragvon WBTMagnum » Mo 4. Mär 2019, 12:56

haydi hat geschrieben:
Mo 4. Mär 2019, 11:51
nein, eine Anleitung für die Erstellung eines Clons gibt es meines Wissens nicht
Stimmt, da gibt es noch gar nichts. Ich habe kurzerhand mal einen Wiki-Eintrag zum Thema "Serverumzug bzw. webEdition Clonen" erstellt. Dann können wir in Zukunft einfach auf die Doku verweisen :D .

HTH,
Sascha

mokraemer
Senior Member
Beiträge: 2769
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Update von 7.0.4 auf 8.1

Beitragvon mokraemer » Mo 4. Mär 2019, 13:36

Danke Sascha. Ich hoffe das wir das Problem mit den Binaries mit WE 8.1 im Backup dann auch beseitigt haben.
webEdition-Kern-Entwickler

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » Mo 4. Mär 2019, 15:09

WBTMagnum hat geschrieben:
Mo 4. Mär 2019, 12:56
haydi hat geschrieben:
Mo 4. Mär 2019, 11:51
nein, eine Anleitung für die Erstellung eines Clons gibt es meines Wissens nicht
Stimmt, da gibt es noch gar nichts. Ich habe kurzerhand mal einen Wiki-Eintrag zum Thema "Serverumzug bzw. webEdition Clonen" erstellt. Dann können wir in Zukunft einfach auf die Doku verweisen :D .

HTH,
Sascha
Cool!

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » Mo 18. Mär 2019, 21:49

Hi Sascha,

danke für die Anleitung. Könntest du sie bitte noch um folgende Punkte ergänzen für Option 1:
- Backup entpackt auf das Zielsystem transferieren?
- In welches Verzeichnis soll das Backup transferiert werden (ins Wurzelverzeichnis?)

Würde mich freuen, wenn du mir die Fragen auch direkt hier beantworten könntest :)

Danke,
Ruby

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1529
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon WBTMagnum » Mo 18. Mär 2019, 23:10

Hallo Ruby,

Das Backup sollte in das Verzeichnis "/webEdition/we_backup/" abgelegt werden. Habe das auch gleich im Wiki vermerkt.

HTH,
Sascha

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » Mo 18. Mär 2019, 23:25

In welchem Format?

rubybadlands
Junior Member
Beiträge: 18
Registriert: So 3. Feb 2019, 15:16

Re: Update von 7.0.4 auf 8.1

Beitragvon rubybadlands » Mo 18. Mär 2019, 23:53

Hi Sascha,

konnte das Backup jetzt einspielen, aber der Rebuild funktioniert nicht. Stockt schon gleich zu Beginn.
Was kann ich machen?

Liebe Grüße,
Ruby

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1529
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Update von 7.0.4 auf 8.1

Beitragvon WBTMagnum » Di 19. Mär 2019, 00:46

rubybadlands hat geschrieben:
Mo 18. Mär 2019, 23:53
konnte das Backup jetzt einspielen, aber der Rebuild funktioniert nicht. Stockt schon gleich zu Beginn. Was kann ich machen?
sh. viewtopic.php?f=86&t=41536&p=101389#p101389


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 3 Gäste