we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen Beitrag ist gelöst

Fragen zum Erstellen von Templates für webEdition.
Scarabaeus
Member
Beiträge: 32
Registriert: Sa 9. Nov 2013, 18:37

we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen

Beitragvon Scarabaeus » Mi 11. Apr 2018, 17:36

Hallo Gemeinde,

ich habe ein Problem mit eine Loginbereich, bei dem verschiedene Mitgliedslevel berücksichtigt werden müssen.
Bei nachstehendem Beispiel wird mir nach dem Einloggen gar kein Inhalt angezeigt.

Code: Alles auswählen

<we:ifNotRegisteredUser>
	<p>Zeigt das Login-Formular</p>
</we:IfNotRegisteredUser>
<we:ifRegisteredUser permission="UserLevel" match="User">
	<p>Zeigt Inhalt für Mietglied</p>
	<we:else />
		<P>Zeigt Inhalt für alle anderen Level (z. B. "Verified")
</we:ifRegisteredUser>
ok, dachte ich, dann eben auf folgende Art:

Code: Alles auswählen

<we:ifNotRegisteredUser>
	<p>Zeigt das Login-Formular</p>
</we:IfNotRegisteredUser>
<we:ifRegisteredUser permission="UserLevel" match="User">
	<p>Zeigt Inhalt für Mietglied</p>
</we:ifRegisteredUser>
<we:ifRegisteredUser permission="UserLevel" match="Verified">
		<P>Zeigt Inhalt für Verified </p>
</we:ifRegisteredUser>
Leider funktioniert auch dies nicht. Die permission-Abfrage scheint in keinem der Fälle zu funktionieren.
Ich habe dann noch einmal das betreffende Feld in der KV von den Einträgen "User" und "Verified" befreit, und stattdessen 0 und 1 verwendet. Auch hier leider ohne Erfolg.

Hat jemand ähnliche Erfahrungen? Und vielleicht auch eine Lösung?
Viele Grüsse
Scarabaeus

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1436
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen

Beitragvon WBTMagnum » Mi 11. Apr 2018, 20:36

Hallo Scarabaeus,

Ich vermute, dass es an "we:ifNotRegisteredUser" != "we:IfNotRegisteredUser" liegt.


Liebe Grüße,
Sascha

Scarabaeus
Member
Beiträge: 32
Registriert: Sa 9. Nov 2013, 18:37

Re: we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen

Beitragvon Scarabaeus » Mi 11. Apr 2018, 20:56

Hallo Sascha,
vielen Dank.

Nein, daran liegt es nicht. Ich hatte den Code hier im Forum händisch eingegeben, nicht per copy & paste. Daher der Schreibfehler.

Ist also immer noch Thema :(
Viele Grüsse
Scarabaeus

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1436
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen

Beitragvon WBTMagnum » Mi 11. Apr 2018, 22:46

Hallo Scarabaeus,

Alles klar! Wäre auch zu einfach gewesen :-).

Hab jetzt kein System bei der Hand wo ich das testen könnte. Welche wE Version hast du denn da im Einsatz.


Liebe Grüße,
Sascha

Scarabaeus
Member
Beiträge: 32
Registriert: Sa 9. Nov 2013, 18:37

Re: we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen

Beitragvon Scarabaeus » Do 12. Apr 2018, 06:26

Das ist eine 8.0.2 Nightly
Viele Grüsse
Scarabaeus

Scarabaeus
Member
Beiträge: 32
Registriert: Sa 9. Nov 2013, 18:37

Re: we:ifNotRegisteredUser Bedingungen scheinen nicht zu gehen  Beitrag ist gelöst

Beitragvon Scarabaeus » Sa 14. Apr 2018, 10:02

Es war ein Fehler in der Abfrage des Feldes.

Der korrekte Code, zumindest in diesem Fall lautet:
<we:ifNotRegisteredUser>
<p>Zeigt das Login-Formular</p>
</we:IfNotRegisteredUser>

<we:ifRegisteredUser permission="Mitgliedslevel_UserLevel" match="User">
<p>Zeigt Inhalt für Mietglied</p>
<we:else />
<p>Zeigt Inhalt für Level "User"
</we:ifRegisteredUser>

<we:ifRegisteredUser permission="Mitgliedslevel_UserLevel" match="Verified">
<p>Zeigt Inhalt für Level "Verified"</p>
</we:ifRegisteredUser>
Viele Grüsse
Scarabaeus


Zurück zu „webEdition Templates erstellen (we:Tags)“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 4 Gäste