Seite 1 von 1

Bilder im Newsletter einbetten

Verfasst: Di 30. Apr 2019, 08:45
von SvenLSK
Hallo WE-Freunde,

ich habe das Problem das die Funktion zum einbetten von Bildern bei mir dazu führt das diese als Anhang mitgeschickt werden, aber nicht im Layout angezeigt werden.

Habe es solwohl mit einer Vorlage versucht welche die Pfade zu den Bilder via http oder https und mit WE-IDs und mit variablen Pfaden aufzeigt.

Im Newsletter-Modul erscheint im Textarea-Feld alles richtig. Ich verwende webEdition 8.

Habt ihr eine Idee?

:?: :?: :?:

Re: Bilder im Newsletter einbetten

Verfasst: Di 30. Apr 2019, 09:47
von WBTMagnum
Hallo Sven,

Ein paar Fragen dazu:
  • Welche webEdition Version ist das konkret?
  • Welche PHP Version verwendest du?
  • Sind Meldungen im webEdition Errorlog (muss aktiviert sein)?
  • Die Option "Bilder in HTML-E-Mails einbetten" ist angewählt?
  • Wie sieht der Quelltext der versendeten E-Mails aus?
Liebe Grüße,
Sascha

Re: Bilder im Newsletter einbetten

Verfasst: Di 30. Apr 2019, 11:27
von SvenLSK
Hi Sascha, danke für die Hilfe.
  • webEdition Version 8.0.3
  • PHP-Version: 7.0.33
  • Keine Meldungen im webEdition Errorlog hierzu
  • Die Option "Bilder in HTML-E-Mails einbetten" ist angewählt.
  • Quelltext der versendeten E-Mail:
    <img style="width: 600px; height: 390px;"src="cid:648b9926a614a4bb20c20551223c62ec" alt="" moz-do-not-send="true" width="600" height="380">

    Quelltext der Vorlage war:
    <img style="width: 600px; height: 390px;" src="/newsletter/1.jpg?id=5&amp;time=1556615321" alt="" width="600" height="380">


    Mir ist aufgefallen das "moz-do-not-send" dazu kommt. Aber auch wenn ich in die Vorlage moz-do-not-send="false" oder moz-do-not-send="true" dazufüge. Bleibt es beim gleichen Ergebnis.
Wähle ich in der Vorlage http-Pfade zu den Bildern aus und sende kommt diese Fehlermedlung im Error-Log:
An Notice occurred while executing a script in webEdition.
URI: /webEdition/we_showMod.php?mod=newsletter&pnt=send_cmd&nid=34&test=false&blockcache=1e84b66262a4414f1ce9fbbddehe25159&emailcache=58475585ed4229550cf6d724566ca927&ecount=1&gcount=2&start=0&egc=0
Error message: Undefined variable: cid
Script name: webEdition/we/include/we_classes/mail/we_mail_mail.class.php
Line number: 277
Caller: errorHandler
Backtrace: #0 we_error_handler::errorHandler called at [webEdition/we/include/we_classes/mail/we_mail_mail.class.php:277]
#1 we_mail_mail->buildMessage called at [webEdition/we/include/we_modules/newsletter/we_newsletter_frames.class.php:1864]
#2 we_newsletter_frames->getHTMLSendCmd called at [webEdition/we/include/we_modules/newsletter/we_newsletter_frames.class.php:96]
#3 we_newsletter_frames->getHTML called at [webEdition/we_showMod.php:259]

Re: Bilder im Newsletter einbetten

Verfasst: Di 30. Apr 2019, 13:07
von Finn
Moin,
hatte die Tage einen ähnlichen Fehler.

Die Lösung war bei mir das Bild über <we:img einzubinden.

Gruß
Finn

Re: Bilder im Newsletter einbetten

Verfasst: Di 30. Apr 2019, 23:31
von SvenLSK
Moin, Moin!

Scheinbar ist es ein bekannter Bug, der schon (gemäß History) in 8.0.5 behoben wurde....ich versuche es nochmal nach dem Update.

Aber auch danke für deine Lösung - macht die Sache dann nochmal sicherer.

Sven

Re: Bilder im Newsletter einbetten

Verfasst: Di 7. Mai 2019, 10:48
von Finn
Hat das Update geholfen? Wäre gut zu wissen :)

Re: Bilder im Newsletter einbetten  Beitrag ist gelöst

Verfasst: Mo 3. Jun 2019, 11:05
von SvenLSK
ja, jetzt geht es wieder :-)