sendMail versendet leere Mails

Fragen zum Erstellen von Templates für webEdition.
Benutzeravatar
eSKa
Senior Member
Beiträge: 548
Registriert: Do 1. Jan 1970, 02:00

sendMail versendet leere Mails

Beitragvon eSKa » Do 29. Aug 2019, 16:43

Hallo zusammen,

vielleicht hat ja jemand eine Idee, da mir dieses Phänomen noch nicht untergekommen ist.

Code: Alles auswählen

<we:sendMail id="96" subject="Bestätigung" recipient="order@xxxxxx.de" from="no-reply@xxx.de" charset="UTF-8" mimetype="text/plain" />
we:sendmail versendet leere E-Mails.
Im Fehler-Protokoll erscheint keine Fehlermeldung.
webEdition Version 8.0.6
Versand erfolgt per smtp (phpmail gleiches Ergebnis)
mimetype="text/html" oder text/plain macht auch keinen Unterschied.
ID 96 ist die ID des Dokuments

Unter einem webEdition 8.0.2 funktioniert der gleiche Code problemlos.

Da keine Fehlermeldung erscheint ist es ziemlich schwer nachzuvollziehen.
Vielleicht ist jemanden hier das gleiche Problem schon untergekommen.

piXel relations GmbH | Agentur für Online-Kommunikation
Luxemburger Str. 93 | 50354 Hürth
Telefon 0 22 33 / 99 66 81
www.pixelrelations.de | info@pixelrelations.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 10:51

Hallo eSKa,

an Deinem Code kann es nicht liegen. Höchstens vielleicht an Deinem Dokument.

Mir fällt da folgendes ein...
Hast Du denn die "no-reply@xxx.de" in den Allgemeinen Einstellungen unter "Formmail" als zulässige E-Mail eingetragen?
Das Sendmail-Dokument als dynamisch abgespeichert?
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 11:02

Ah sorry,

jetzt sehe ich am Titel: leere Mails, will heißen, die E-Mails kommen an aber sind leer? hmmm...

Hast Du den notwendigen Inhalt direkt in das Dokument geschrieben oder fütterst Du das Sendmail-Dokument mit einem Template?
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

Benutzeravatar
eSKa
Senior Member
Beiträge: 548
Registriert: Do 1. Jan 1970, 02:00

Re: sendMail versendet leere Mails

Beitragvon eSKa » Fr 30. Aug 2019, 12:00

vieln Dank für die Rückmeldung.

... ja richtig. Die Mails werden versendet, sind aber leer.

Die Inhalte liegen in einem Template und das Dokument ist dynamisch gespeichert.

Ich hatte auch schon einfachste Inhalte (nur Zeichen) getestet, um auszuschließen, dass es an dem Code liegt.

Im Moment finden wir da gar keinen Ansatz.

piXel relations GmbH | Agentur für Online-Kommunikation
Luxemburger Str. 93 | 50354 Hürth
Telefon 0 22 33 / 99 66 81
www.pixelrelations.de | info@pixelrelations.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 12:38

Hmm...

Ist vielleicht eine blöde Idee, aber hast Du schon mal in den Spam-Ordner geschaut? Auch Quatsch - ich vergess immer, dass die Mails ja ankommen.

Poste doch einfach mal dein Mail-Template...
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 12:45

Ah noch etwas,

wenn Du das Mail-Dokument im Backend öffnest und auf den Reiter "Vorschau" klickst, sind dann die Inhalte des Templattes sichtbar?
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

Benutzeravatar
eSKa
Senior Member
Beiträge: 548
Registriert: Do 1. Jan 1970, 02:00

Re: sendMail versendet leere Mails

Beitragvon eSKa » Fr 30. Aug 2019, 12:48

... das kann ich gerne machen. Das absurde ist, ausser ein paar Felder aus der Kundenverwaltung steht da noch nichts drin.
Aber wie gesagt, in einer 8.0.2 Version läuft diese Mail problemlos.

Code: Alles auswählen

<!doctype html>
<html>
<head>
<meta charset="utf-8">
<title>Mail</title>
</head>
<body>
<we:sessionField name="Kontakt_Firma" type="print"/><br/>
<we:sessionField name="Anrede_Anrede" type="print"/> <we:sessionField name="Forename" type="print"/> <we:sessionField name="Surname" type="print"/><br/>
<we:sessionField name="Kontakt_Strasse" type="print"/>,&nbsp;<we:sessionField name="Kontakt_PLZ" type="print"/>&nbsp;<we:sessionField name="Kontakt_Ort" type="print"/><br/>
<we:sessionField name="Kontakt_Email" type="print"/><br/>
</body>
</html>

piXel relations GmbH | Agentur für Online-Kommunikation
Luxemburger Str. 93 | 50354 Hürth
Telefon 0 22 33 / 99 66 81
www.pixelrelations.de | info@pixelrelations.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 12:55

Also ich kann da nichts falsches erkennen.

Zwar baue ich diesen Mailversand etwas umfangreicher auf (mit E-Mail-Master und div. Templates für diverse E-Mail-Inhalte) aber ansonsten müsste es imho so gehen, wie Du es erstellt hast.

Ich würde an Deiner Stelle jetzt einfach mal einen "Test-Satz" reincoden, der nichts mit den we:sessionFields zu tun hat.
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

Benutzeravatar
eSKa
Senior Member
Beiträge: 548
Registriert: Do 1. Jan 1970, 02:00

Re: sendMail versendet leere Mails

Beitragvon eSKa » Fr 30. Aug 2019, 13:13

ja, eigentlich sind wir auch gerade erst am Start, die Mail aufzubauen, daher der reduzierte Inhalt. Da dieser aber schon nicht angezeigt wurde, wurden wir sekeptisch.
Ich hatte auch schon versucht, nur Text zu versenden ... ohne Erfolg.

Wir werden mal weitersuchen.

Vielen Dank schon mal für deinen Einsatz.

piXel relations GmbH | Agentur für Online-Kommunikation
Luxemburger Str. 93 | 50354 Hürth
Telefon 0 22 33 / 99 66 81
www.pixelrelations.de | info@pixelrelations.de

mediavantis
Senior Member
Beiträge: 134
Registriert: Do 16. Feb 2012, 12:51

Re: sendMail versendet leere Mails

Beitragvon mediavantis » Fr 30. Aug 2019, 13:18

... nicht dafür

Aber sobald Du den Grund dafür erkennst, wäre es nett, wenn Du das posten würdest.
Viele Grüsse
Ulrich

mediavantis informationsdesign - Düsseldorf
Bublitzer Str. 34 - 40599 Düsseldorf
Telefon: +49 211 74969674
https://www.mediavantis.de - info@mediavantis.de

Benutzeravatar
eSKa
Senior Member
Beiträge: 548
Registriert: Do 1. Jan 1970, 02:00

Re: sendMail versendet leere Mails

Beitragvon eSKa » Di 3. Sep 2019, 16:48

... wir haben es leider nicht geschafft über sendMail E-Mails zu versenden. Bzw. die Mails wurden versendet, der Inhalt aber nicht.

Wir haben das ganze mit PHPMailer jetzt "zu Fuß" gebaut. Den Weg hätten wir wohl eh gewählt, da wir zukünftig auch Anhänge mit versenden wollen und das ja mit sendMail leider nicht geht.

Trotzdem Danke!

piXel relations GmbH | Agentur für Online-Kommunikation
Luxemburger Str. 93 | 50354 Hürth
Telefon 0 22 33 / 99 66 81
www.pixelrelations.de | info@pixelrelations.de

mokraemer
Senior Member
Beiträge: 2923
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: sendMail versendet leere Mails

Beitragvon mokraemer » Di 3. Sep 2019, 19:55

hättet ihr den Fehler hier gesucht und die Anhänge implementiert, hätten alle was davon gehabt.
webEdition-Kern-Entwickler

ThomasGoebe
Senior Member
Beiträge: 864
Registriert: Mo 26. Jul 2010, 23:44
Wohnort: Hannover
Kontaktdaten:

Re: sendMail versendet leere Mails

Beitragvon ThomasGoebe » Di 3. Sep 2019, 20:08

mokraemer hat geschrieben:
Di 3. Sep 2019, 19:55
hättet ihr den Fehler hier gesucht und die Anhänge implementiert, hätten alle was davon gehabt.
Habe ich 2016 bereits gemacht, ist seitdem nichts in der Richtung passiert...
https://qa.webedition.org/tracker/view.php?id=7211
Thomas Göbe
webEdition Experte aus Hannover
Autor des 1. webEdition Buch (gemeinsam mit Andreas Witt)
web: http://www.projektheimat.de

mokraemer
Senior Member
Beiträge: 2923
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: sendMail versendet leere Mails

Beitragvon mokraemer » Di 3. Sep 2019, 21:43

könnte daran liegen das du es an einen 3 Jahre alten FR gehängt hast und es dann einfach untergegangen ist.
Aber, wenn wir da was haben, dann integriere ich das für 8.0.7.
webEdition-Kern-Entwickler

bolleone
Senior Member
Beiträge: 594
Registriert: So 4. Jul 2004, 00:24
Wohnort: Düsseldorf
Kontaktdaten:

Re: sendMail versendet leere Mails

Beitragvon bolleone » Di 17. Sep 2019, 15:42

Hallo in die Runde,

ich springe hier mal auf: Ich habe aktuell bei einer Installation das gleiche Problem:
Server: Strato
WE-Version: 8.1.0.0 (Revision: 10599 default), hatte es davor auch mit der 8.0.5 probiert (bei der Version war meinem Kunden das aufgefallen)

Ich habe exakt den gleichen Code verwendet, den ich bei vielen anderen Websites aktuell auch einsetze. Einziger Unterschied: Provider ist Strato.

Ergebnis: "Document to send via we:sendMail is empty ID: 568", die Mail wird verschickt, der Mailbody ist aber komplett leer.
multimediadesign.net · Atelier für Kommunikation
Grimmstr. 3 · 40235 Düsseldorf
Telefon ++49-211-4981791 · Telefax ++49-211-4981792
http://www.multimediadesign.net · bolle@multimediadesign.net


Zurück zu „webEdition Templates erstellen (we:Tags)“

Wer ist online?

Mitglieder in diesem Forum: MSN [Bot] und 5 Gäste