OnlineInstaller geht nicht weiter

Fragen und Infos zur Installation & Update von webEdition.
frog0815
Junior Member
Beiträge: 25
Registriert: Mo 7. Apr 2014, 14:25

OnlineInstaller geht nicht weiter

Beitragvon frog0815 » Do 25. Jul 2019, 12:03

Hallo,

ich habe schon mehrere 8.0.x webEdition Installationen durchgeführt.
Aber mit der aktuellen Version 8.1 hängt der Installer im Schritt "Login".
Alle Zugangsdaten sind eingetragen und man klickt auf weiter und es passiert dann einfach nichts.

Woran liegt das?

PHP Version 7.2.11

In der Datei installer.err sind von dieser Art Meldung viele verschiedene Einträge.
{XXX} steht dabei für z.B. LicenceAgreement, DocumentRoot, SystemRequirements, InstallationDirectory, Database, ...

Code: Alles auswählen

Array
(
    [type] => 2
    [message] => Declaration of {XXX}::execute(&$Template = '') should be compatible with leStep::execute(leTemplate $Template)
    [file] => /OnlineInstaller/ApplicationInstaller/includes/wizards/Settings/LicenceAgreement.class.php
    [line] => 64
    [backtrace] => Array
        (
            [0] => Array
                (
                    [file] => /OnlineInstaller/OnlineInstaller/includes/library/leWizard.class.php
                    [line] => 26
                    [function] => liveUpdateErrorHandler
                )

            [1] => Array
                (
                    [file] => /OnlineInstaller/OnlineInstaller/includes/library/leWizard.class.php
                    [line] => 26
                    [function] => require_once
                )

            [2] => Array
                (
                    [file] => /OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php
                    [line] => 203
                    [function] => __construct
                    [class] => leWizard
                    [type] => ->
                )

            [3] => Array
                (
                    [file] => /OnlineInstaller/setup.php
                    [line] => 149
                    [function] => initialize
                    [class] => leOnlineInstaller
                    [type] => ->
                )
        )
)

WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1661
Registriert: Di 7. Mär 2006, 16:50
Wohnort: Wien
Kontaktdaten:

Re: OnlineInstaller geht nicht weiter

Beitragvon WBTMagnum » Do 25. Jul 2019, 12:35

Hallo,

Dürfte das selbe Problem sein wie hier beschrieben: viewtopic.php?f=86&t=41596

Schlage vor einen Eintrag in der Bugbase zu machen.


Liebe Grüße,
Sascha

frog0815
Junior Member
Beiträge: 25
Registriert: Mo 7. Apr 2014, 14:25

Re: OnlineInstaller geht nicht weiter

Beitragvon frog0815 » Fr 26. Jul 2019, 08:38

Ja scheint dasselbe zu sein.
Anscheinend gibt es noch keine Lösung.

Habe noch die webEdition_8040.tgz und webEdition_7040.tgz versucht zu installieren die scheinen auch defekt zu sein. Im Schritt bei den DB Zugangsdaten kommen immer die Fehlermeldungen zu jedem Feld das man die Zugangsdaten eintragen soll, als hätte man keinen Wert eingetragen.

webEdition_6450.tgz hat dann funktioniert und konnte von dort auf 8.0.6 updaten. Etwas umständlich :?

Benutzeravatar
Finn
Senior Member
Beiträge: 108
Registriert: Mo 3. Apr 2017, 13:37
Wohnort: Bremen
Kontaktdaten:

Re: OnlineInstaller geht nicht weiter

Beitragvon Finn » Fr 26. Jul 2019, 12:33

Gleiches Problem bei mir :( Nur das meine Installation noch vor dem Eingeben der DB Verbindung stehen bleibt.
Finn Thorwarth
WG Werbeagentur
https://www.wg-werbeagentur.de

mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: OnlineInstaller geht nicht weiter

Beitragvon mokraemer » Fr 26. Jul 2019, 18:33

hab zwar ne neue Version hochgeladen, denke aber das es vor Montag nicht stabil wird.
webEdition-Kern-Entwickler

mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: OnlineInstaller geht nicht weiter

Beitragvon mokraemer » Sa 27. Jul 2019, 20:51

So. Der neue Installer ist nun auch fertig.
Optisch hat sich wenig getan, technisch kann man nun auf dem Server die (gefährliche) Funktion "eval" deaktivieren. Lediglich das Update bis Version 8.0.3 benötigt eval weiterhin.
webEdition-Kern-Entwickler

Benutzeravatar
Finn
Senior Member
Beiträge: 108
Registriert: Mo 3. Apr 2017, 13:37
Wohnort: Bremen
Kontaktdaten:

Re: OnlineInstaller geht nicht weiter

Beitragvon Finn » Mo 29. Jul 2019, 09:54

Super, bei mir gehts wieder!
Finn Thorwarth
WG Werbeagentur
https://www.wg-werbeagentur.de

statist
Senior Member
Beiträge: 115
Registriert: Mo 12. Dez 2011, 14:46

Re: OnlineInstaller geht nicht weiter

Beitragvon statist » Mo 29. Jul 2019, 10:34

Sorry, muss noch einen Fehler melden. Der Installer klappt nun wieder super, allerdings kommt beim Login-Versuch diese Meldung (auch nach Warten von 45 Min wegen der Tokens):
webEdition konnte nicht gestartet werden!\n\nAus Sicherheitsgründen wurde der Loginvorgang abgebrochen, da die maximale Anmeldezeit überschritten wurde!\n\nBitte melden Sie sich neu an.
Hab alle 8er-Versionen durchprobiert, ist überall identisch

Benutzeravatar
Finn
Senior Member
Beiträge: 108
Registriert: Mo 3. Apr 2017, 13:37
Wohnort: Bremen
Kontaktdaten:

Re: OnlineInstaller geht nicht weiter

Beitragvon Finn » Mo 29. Jul 2019, 11:24

Muss mich korrigieren der nstaller funktioniert unter PHP 7.x aber nicht unter 5.6 Da gibts ne weiße Seite
Finn Thorwarth
WG Werbeagentur
https://www.wg-werbeagentur.de


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 4 Gäste