Keine Verbindung zum Update-Server

Fragen und Infos zur Installation & Update von webEdition.
mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Keine Verbindung zum Update-Server

Beitragvon mokraemer » Do 16. Jan 2020, 23:17

hast du nur die beiden Extrem-Versionen? 5.6 und 7.3? Die Versionsumstellung von PHP ist durch die vielen Änderungen recht hakig.
Hast du in WE das Fehlerlog mit allem aktiviert?
Hat der Hoster evtl. noch ein Fehlerlog (nicht alle PHP Fehler können gefangen werden und landen am Ende sonst nur noch im Servelog).

Wenn der Installer bei der Ermittlung der Dateien hängen bleibt, spricht das für einen fatal Error nachdem die Installer-Dateien vom Updateserver kamen. Mit welcher PHP Version hast du denn welche WE-Version versucht zu installiieren (die Dateien sind nämlich von der Zielversion abhängig)
webEdition-Kern-Entwickler

TimEschke
Junior Member
Beiträge: 15
Registriert: Fr 20. Apr 2018, 11:54

Re: Keine Verbindung zum Update-Server

Beitragvon TimEschke » Fr 17. Jan 2020, 12:19

mokraemer hat geschrieben:
Do 16. Jan 2020, 23:17
hast du nur die beiden Extrem-Versionen? 5.6 und 7.3? Die Versionsumstellung von PHP ist durch die vielen Änderungen recht hakig.
Hast du in WE das Fehlerlog mit allem aktiviert?
Hat der Hoster evtl. noch ein Fehlerlog (nicht alle PHP Fehler können gefangen werden und landen am Ende sonst nur noch im Servelog).

Wenn der Installer bei der Ermittlung der Dateien hängen bleibt, spricht das für einen fatal Error nachdem die Installer-Dateien vom Updateserver kamen. Mit welcher PHP Version hast du denn welche WE-Version versucht zu installiieren (die Dateien sind nämlich von der Zielversion abhängig)
PHP Versionen die ich zur Verfügung habe: 5.6 und 7.0, 7.1, 7.2, 7.3, 7.4

Wie beschrieben funktioniert das installierte webEdition und die Website in der Live-View nur unter PHP 5.6.
Bei der Fehlerdokumentation im webEdition sind alle Haken für Fehler, Warnungen und Hinweise gesetzt und werden ausschließlich im Fehlerlog dokumentiert.
Logging für PHP Fehler ist auch aktiviert und in der Error-Log im HTML-Root und im webEdition Ordner finde ich keine Hinweise auf Fehler während dem Update-Prozess.
Lediglich den nachstehenden Fehler aus der error_log des webEdition habe ich ausfindig machen können, es ist der einzige Eintrag der jünger ist als 6 Monate:
[16-Jan-2020 14:11:43 UTC] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/hotelplatz/public_html/webEdition/we/include/we_error_handler.inc.php:335


Zum Versuch der Installation auf der Subdomain:
Ich habe es mit jeder der oben beschriebenen 7bener Versionen versucht. Ein Screenshot von dem Punkt wo es hängen bleibt habe ich angehängt. Ich komme noch nicht einmal bis zur Auswahl der wE Version. Bei der Abfrage der "PHP-Version, Session & Cookies" geht es nicht weiter. Da waren meine Informationen aus dem letzten Post nicht ganz genau. Sorry für die falschen Informationen.
Nachstehend noch der Fehler aus dem Fehlerlog bei dem Versuch der Neu-Installation:
[14-Jan-2020 10:53:28 UTC] PHP Parse error: syntax error, unexpected '?' in /home/hotelplatz/test.hotelplatz.it/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php on line 211
[17-Jan-2020 09:38:37 UTC] PHP Parse error: syntax error, unexpected '?' in /home/hotelplatz/test.hotelplatz.it/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php on line 211
[17-Jan-2020 09:38:40 UTC] PHP Parse error: syntax error, unexpected '?' in /home/hotelplatz/test.hotelplatz.it/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php on line 211
Dateianhänge
16-01-2020 Installer bleibt hängen.png
16-01-2020 Installer bleibt hängen.png (36.3 KiB) 1063 mal betrachtet

mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Keine Verbindung zum Update-Server

Beitragvon mokraemer » Fr 17. Jan 2020, 12:56

Update:
[16-Jan-2020 14:11:43 UTC] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/hotelplatz/public_html/webEdition/we/include/we_error_handler.inc.php:335
Ja, das ist natürlich sau blöd: die Version 6.3 war noch für PHP 5.3 gedacht und da gab es die Erweiterung noch, die wurde dann mit PHP 5.5 entfernt und ihr nutzt jetzt schon 5.6 damit....
Dann solltest du mal beim Fehlerlog eine Mail-Adresse eintragen und das Senden von Fehlern an die Mail aktivieren. Dann sollte man den eigentlichen Fehler hier finden und beheben können.

Installation:
[14-Jan-2020 10:53:28 UTC] PHP Parse error: syntax error, unexpected '?' in /home/hotelplatz/test.hotelplatz.it/OnlineInstaller/OnlineInstaller/includes/library/leOnlineInstaller.class.php on line 211
was hier angemeckert wird ist gültiger Syntax von PHP 7.1! Den Fehler erhalte ich auch nicht, wenn ich das hier versuche. (?)
webEdition-Kern-Entwickler

TimEschke
Junior Member
Beiträge: 15
Registriert: Fr 20. Apr 2018, 11:54

Re: Keine Verbindung zum Update-Server

Beitragvon TimEschke » Fr 17. Jan 2020, 16:28

Ja, das ist natürlich sau blöd: die Version 6.3 war noch für PHP 5.3 gedacht und da gab es die Erweiterung noch, die wurde dann mit PHP 5.5 entfernt und ihr nutzt jetzt schon 5.6 damit....
Dann solltest du mal beim Fehlerlog eine Mail-Adresse eintragen und das Senden von Fehlern an die Mail aktivieren. Dann sollte man den eigentlichen Fehler hier finden und beheben können.
Meinst du es wäre eine Möglichkeit das ganze unter PHP 5.3 mal auszuprobieren?
Ich sehe grade ich habe hier von PHP 5.1 bis 5.6 alles zur auswahl, erstaunlicherweise sogar PHP 4.4.
Fehlerlog zur E-Mailadresse aktiviere ich mal.

mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Keine Verbindung zum Update-Server

Beitragvon mokraemer » Sa 18. Jan 2020, 12:50

5.4 ist eine gute Wahl für die Version zum Update auf 6.4 - was ich ganz vergessen hatte:
WE bis 6.3.6 hat die Verbindung zum Updateserver noch per http und nicht per https gemacht; die alte WE Version versteht aber das upgrade von http->https nicht. Du müßtest auf jeden Fall per Hand in folgenden Dateien in der Zeile das http durch https ersetzen.

Code: Alles auswählen

webEdition/we/include/we_classes/leWizard/liveUpdateHttpWizard.class.php:<form id="liveUpdateForm" action="http://' . LIVEUPDATE_SERVER . LIVEUPDATE_SERVER_SCRIPT . '" method="post">
webEdition/liveUpdate/classes/liveUpdateHttp.class.php:<form id="liveUpdateForm" action="http://' . LIVEUPDATE_SERVER . LIVEUPDATE_SERVER_SCRIPT . '" method="post">
webEdition-Kern-Entwickler

TimEschke
Junior Member
Beiträge: 15
Registriert: Fr 20. Apr 2018, 11:54

Re: Keine Verbindung zum Update-Server

Beitragvon TimEschke » Mo 20. Jan 2020, 15:51

mokraemer hat geschrieben:
Sa 18. Jan 2020, 12:50
5.4 ist eine gute Wahl für die Version zum Update auf 6.4 - was ich ganz vergessen hatte:
WE bis 6.3.6 hat die Verbindung zum Updateserver noch per http und nicht per https gemacht; die alte WE Version versteht aber das upgrade von http->https nicht. Du müßtest auf jeden Fall per Hand in folgenden Dateien in der Zeile das http durch https ersetzen.
Nur nochmal um sicherzugehen, bevor ich die von dir beschriebenen Änderungen durchführe und ein Update mit PHP 5.4 versuche.

Ich versuche ein Update aus Version wE 6.4.1 auf 7.0.4 durchzuführen. Was wäre dann die optimale PHP-Version? Und müssen die Änderungen zum http/https in den beschriebenen Dateien dann noch gemacht werden?

mokraemer
Senior Member
Beiträge: 3198
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Keine Verbindung zum Update-Server

Beitragvon mokraemer » Mo 20. Jan 2020, 20:00

sorry, gibt grad 2 ähnliche Beiträge zum Thema Updates, bin da wohl durcheinander geraten.
Die Änderungen https mußt du mit we 6.4.1 nicht mehr machen,

Mach doch erst mal das Update von 6.4.1 auf 6.4.4 (ohne Rebuild) mit php 5.5, danach kannst du auf WE 7 gehen und PHP 5.6 bzw. PHP 7 nutzen.
webEdition-Kern-Entwickler

TimEschke
Junior Member
Beiträge: 15
Registriert: Fr 20. Apr 2018, 11:54

Re: Keine Verbindung zum Update-Server

Beitragvon TimEschke » Di 21. Jan 2020, 16:27

mokraemer hat geschrieben:
Mo 20. Jan 2020, 20:00
sorry, gibt grad 2 ähnliche Beiträge zum Thema Updates, bin da wohl durcheinander geraten.
Die Änderungen https mußt du mit we 6.4.1 nicht mehr machen,

Mach doch erst mal das Update von 6.4.1 auf 6.4.4 (ohne Rebuild) mit php 5.5, danach kannst du auf WE 7 gehen und PHP 5.6 bzw. PHP 7 nutzen.
Leider geht auch das Update mit PHP 5.5 von wE 6.4.1 auf wE 6.4.5 nicht. (habe leider kein 6.4.4 in der Liste).
Update bleibt beim nachtsehenden Screenshot einfach hängen.
Dateianhänge
21-01-2020 Updater bleibt hängen.png
21-01-2020 Updater bleibt hängen.png (23.36 KiB) 968 mal betrachtet

Rala
Member
Beiträge: 58
Registriert: Fr 26. Jan 2007, 09:04
Wohnort: Dormagen
Kontaktdaten:

Re: Keine Verbindung zum Update-Server

Beitragvon Rala » Di 21. Jan 2020, 18:00

Ich wollte eine frische Installation vornehmen (kein Update) und erhalte gestern und heute (20./21.1.2020) ebenfalls die Meldung, dass keine Verbindung zum Server möglich ist. Ist das nur ein zeitweises Problem?
Dateianhänge
Screenshot_2020-01-21 webEdition Online Installer.png
Screenshot_2020-01-21 webEdition Online Installer.png (22.06 KiB) 965 mal betrachtet


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste