Probleme beim we:Form

Fragen zum Erstellen von Templates für webEdition.
YäiDee

Probleme beim we:Form

Beitragvon YäiDee » Di 2. Mär 2010, 13:37

Hallo Leute.

Ich versuche aktuell verzweifelt meine Form zum laufen zu bekommen. Jedoch wenn ich die Form teste wird die Fehlerseite "formsenterror" angesteuert die besagt das bei meiner Emailadresse die Syntax nicht stimmt. Wobei in meinen Augen Name@Dormain.Ländercode also Hans@Traumwelt.net in der regel richtig sein sollte? Oder etwa nicht?

Mein code sie so aus:

Code: Alles auswählen

     <we:form type="formmail" recipient="info@xxxxxx.de" from="info@xxxxxx.de" subject="TTR Group GmbH - Kontaktformular Website" onerror="421" onsuccess="420" onmailerror="422" confirmmail="true" preconfirm="EMailtextVorFeldern" postconfirm="EMailtextNachFeldern" xml="true" /> 
       <p><br />* Pflichtfelder</p><br />
	<FIELDSET><LEGEND>Ihre Angaben</LEGEND><br />
        <p><label for="formSelect_Anrede">Anrede*:</label>
        <select size="1" name="Anrede" id="formSelect_Anrede">
         <option></option>
         <option value="Frau">Frau</option> 
         <option value="Herr">Herr</option>
         </select>
        </p>
        <p>
         <label for="formInput_Vorname">Vorname:</label>
         <input type="text" name="Vorname" id="formInput_Vorname" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Name">Name*:</label>
         <input type="text" name="Name" id="formInput_Name" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Unternehmen">Unternehmen*:</label>
         <input type="text" name="Unternehmen" id="formInput_Unternehmen" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Abteilung">Abteilung:</label>
         <input type="text" name="Abteilung" id="formInput_Abteilung" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Position">Position:</label>
         <input type="text" name="Position" id="formInput_Position" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Strasse">Straße:</label>
         <input type="text" name="Strasse" id="formInput_Strasse" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Hausnummer">Hausnummer:</label>
         <input type="text" name="Hausnummer" id="formInput_Hausnummer" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_PLZ"><abbr title="Postleitzahl">PLZ*:</abb></label>
         <input type="text" name="PLZ" id="formInput_PLZ" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Ort">Ort*:</label>
         <input type="text" name="Ort" id="formInput_Ort" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_Telefon">Telefon:</label>
         <input type="text" name="Telefon" id="formInput_Telefon" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
         <label for="formInput_EMailAdresse">E-Mail*:</label>
         <input type="text" name="email" id="formInput_EMailAdresse" maxlength="80" html="false" htmlspecialchars="false" php="false" />
        </p>
        <p>
          <label for="formTextarea_Nachricht">Nachricht:</label>
          <textarea cols="19" rows="6" name="Nachricht" id="formTextarea_Nachricht" maxlength="150" html="false" htmlspecialchars="false" php="false" /></textarea>
        </p>
       </FIELDSET>
        <p>
          <input type="button" onclick="javascript:CheckInput();" value="Senden" id="formInput_submit" />
          <input type="reset" value="Löschen" id="formInput_reset" />
        </p>
       </we:form>
Hat irgendjemand eine Ahnung was das sein könnte? =)

Edit: Als zusatzinfo es kommt die Fehlermeldung:

Das Formular wurde aus folgendem Grund nicht übermittelt:
• Empfängeradresse nicht gültig!

:(

MarS
Senior Member
Beiträge: 602
Registriert: Mo 2. Mai 2005, 11:30
Wohnort: Kiel
Kontaktdaten:

Re: Probleme beim we:Form

Beitragvon MarS » Di 2. Mär 2010, 14:00

Ist die Adresse in den Einstellungen unter dem Tab Formmail hinterlegt?
Wir nutzen das leider nicht, aber ich meine, jede Adresse, die man dort einträgt muss in den Einstellungen hinterlegt werden.

Gruß, Martin

e_herrmann
Senior Member
Beiträge: 1283
Registriert: Do 22. Mai 2003, 23:25

Re: Probleme beim we:Form

Beitragvon e_herrmann » Di 2. Mär 2010, 14:09

genau gesagt geht es um diese Adresse recipient="info@xxxxxx.de"
Du kannst ein Formular nur versenden wenn die Empfängeradresse eingetragen ist.
Sonst wäre es recht einfach aus dem Formular eine Spam-Schleuder zu machen.
Grüße Elko
Elko Herrmann
komplexx | internet.fotografie
web: http://www.komplexx.de

YäiDee

Re: Probleme beim we:Form

Beitragvon YäiDee » Di 2. Mär 2010, 14:29

*in den Boden schäm*

Man kann ein Brett vorm Kopf haben, ich hatte glaub ich den Kompletten Urwalt vor der Stirn :(

Ich danke euch 1000x ich hatte vergessen den Empfänger in den Einstellungen zu Setzten -> Eingetragen und es funktioniert ~.~

Das "info@xxxxxx.de" war nur geschwärzt zum Schutze meines Arbeitgebers :)

1000 Dank euch und einen hoffentlich bald wunderschönen Feierabend ;)


Zurück zu „webEdition Templates erstellen (we:Tags)“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 13 Gäste