Editor Plugin startet nicht

Hier können Sie Fragen bezüglich des Editor PlugIns stellen.
flexgabriel

Editor Plugin startet nicht

Beitragvon flexgabriel » Di 22. Jun 2010, 16:30

Hallo liebes Team

seit neuestem funktioniert mein Editor Plugin nicht mehr. Das kleine Popup geht auf "webEdition plugin Initialisation" und zeigt nach recht langem Timeout diese JS-Fehlermeldung:

Es scheint, dass das Java-Plugin nicht installiert oder nicht aktiviert ist. Für das Editor-Plugin wird Sun Java ab Version 1.4.2_05 benötigt.
Das ganze probierte ich auf einem Mac OSX 10.5 mit Firefox 3.6.3 oder Safari 5, java -version zeigt 1.5.0_24.

Bin um jeden Tipp dankbar, auch Hinweise wie man prüft, ob das Editor-Plugin korrekt aktiviert ist etc.

flexgabriel

Re: Editor Plugin startet nicht

Beitragvon flexgabriel » Mi 23. Jun 2010, 11:31

Kann mir keiner helfen?

flexgabriel

Re: Editor Plugin startet nicht

Beitragvon flexgabriel » Mi 7. Jul 2010, 00:17

Schade das Forum ist tot.

we:willRockYou
Senior Member
Beiträge: 919
Registriert: Fr 22. Mai 2009, 21:40
Wohnort: Berlin
Kontaktdaten:

Re: Editor Plugin startet nicht

Beitragvon we:willRockYou » Mi 7. Jul 2010, 06:56

Nein, es nutzt nur niemand das Editor-Plugin.

Da Du "kürzlich" schreibst: Kürzlich gab es auch ein Java-Update auf OS X. Vielleicht funktionierts nicht mit der neuen Version.

Da das Plugin auf die Festplatte zugreift ist die Signatur dabei wichtig. Und die Signatur der Java-Applets ist seit einer Weile abgelaufen. Allerdings funktioniert das JUpload bei mir auf OS X noch. Bei einem Kunden allerdings nicht mehr, da wird es von irgendwelchem Security-Zeugs rausgefiltert.

Funktioniert das JUpload bei Dir noch?
EOF; //totally retired

flexgabriel

Re: Editor Plugin startet nicht

Beitragvon flexgabriel » Sa 10. Jul 2010, 01:55

Oh ein Lebenszeichen, danke!

Also auf meinem Windows Rechner startet der Hook für einen externen Editor auch nicht. Es muss also mit dem Zertifikat zusammenhängen, denn hier habe ich die Java Version nicht verändert und es lief vorher. An wen muss ich mich denn wenden, damit der Urheber (webEdition Team?) das Zertifikat erneuert / bzw verlängert?
Das wäre doch die einzige Möglichkeit, oder?

we:willRockYou
Senior Member
Beiträge: 919
Registriert: Fr 22. Mai 2009, 21:40
Wohnort: Berlin
Kontaktdaten:

Re: Editor Plugin startet nicht

Beitragvon we:willRockYou » Sa 10. Jul 2010, 07:32

Mache hier einen Bugreport.

Vorerst wirst Du da aber vermutlich mit nichts rechnen können. Ein "echtes" Zertifikat kostet eine Gebühr pro jahr, ich glaube so um die 100€. Da noch kein Verein existiert, gibt es auch niemand der die Rechnung dafür zahlen könnte, es sei denn es meldet sich jemand freiwillig und nimmt das auf seine Kappe.

Ich hatte das Thema schon vor einer Weile in der Entwicklerliste angesprochen. Hier eine Antwort von Alex zu dem Thema damals:
Deswegen Geld rauszuwerfen halte ich nur für
medium sinnvoll. Der Einzige Grund für ein richtiges Zertifikat ist
das Editor Plugin, und darum können wir uns eh erst kümmern wenn der
Verein steht. Bis dahin ist das Zertifikat halt entweder ungültig
oder
auf irgendjemanden von uns ausgestellt.
Entweder wir lassen also die Zertifikate halt auslaufen (ob die CA
unbekannt oder das Zertifikat abgelaufen ist kommt dann eigentlich
aufs selbe raus) oder wir müssen halt den Namen von irgendjemandem
reinschreiben. Was anderes bleibt uns kurzfristig gesehen eigentlich
nicht übrig.
Der Quellcode des Editor-Plugins liegt auch auf dem SVN-Server. Man könnte das also auch im Alleingang machen. Applet neu kompilieren und mit einem eigenen Zertifikat signieren. ...Mit dem entsprechenden Wissen. Ich kenne mich da aber auch nicht aus. :)
EOF; //totally retired

flexgabriel

Re: Editor Plugin startet nicht

Beitragvon flexgabriel » Sa 10. Jul 2010, 13:47

Danke Daniel!!

Du hast mir sehr weitergeholfen. Kenne mich ein bissel aus, ich werde mir den Quellcode ziehen und mir ein dafür Zertifikat machen.
Das mit einem "offiziellen" Zertifikat ist natürlich für eine open-source Gemeinde kaum machbar, es sei denn webEditon Verein -> Spenden. Hier müsste man mMn die Community stärker einbeziehen.

Für alle anderen, die hier auch eine Lösung brauchen, ladet euch den Quelltext des Applets runter, compiliert daraus eine jar Datei und dann signiert ihr es: http://wiklet.javacore.de/index.php/Sig ... on_Applets.

flexgabriel

Re: Editor Plugin startet nicht

Beitragvon flexgabriel » Sa 10. Jul 2010, 15:42

So hier mal des selbst signierte editorplugin. Ohne Gewähr da ich es im Moment nicht testen kann.
editorPlugin.zip
.zip in .jar umbenennen! (da .jar files im forum nicht erlaubt sind)
(74.51 KiB) 186-mal heruntergeladen
Compiliert mit jdk1.6_20
Ausgestellt auf: webedition, de
Läuft ab am: 07.07.2020

Bei Aufruf sollte im Browser eine zusätzliche Warnung kommen, dass das Applet "not trusted" ist und ob man es wirklich ausführen möchte ;)

rhorbas
webEdition Gold Partner
webEdition Gold Partner
Beiträge: 189
Registriert: Do 1. Jan 1970, 02:00

Re: Editor Plugin startet nicht

Beitragvon rhorbas » Mi 4. Mai 2011, 16:18

Ich poste hier mal, was ich dazu weiß, denn ich falle immer wieder mal darauf rein, wie auch diesmal wieder: Das Editor Plugin verträgt sich nicht mit eigenen 404 Error Pages. Die im OP genannte Java-Fehlermeldung ist da ziemlich irreführend! (Ich habe auch diesmal wieder mein Java aktualisiert, aber ohne Erfolg).
Wer also in der .htaccess etwas hat wie:

Code: Alles auswählen

ErrorDocument 404 http://www.example.com/404.php
sollte die Zeile solange auskommentieren, bis die Entwicklung an der Website abgeschlossen ist (das Editor Plugin benötigt man sonst i.d.R. zumindest für Templates nicht).

Falls noch jemand eine andere, elegantere Lösung hat, würde ich mich freuen!
Ich habe leider nichts gefunden, um z.B. die Direktive für ein bestimmtes Verzeichnis aufzuheben.

Rudi


Zurück zu „Editor PlugIn“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast