Verbindung zum Update-Server

Fragen und Infos zur Installation & Update von webEdition.
WBTMagnum
webEdition Partner
webEdition Partner
Beiträge: 1460
Registriert: Di 7. Mär 2006, 16:50
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon WBTMagnum » Do 27. Apr 2017, 17:16

Nur zur Sicherheit: Speicherplatz ist ausreichend vorhanden?

Liebe Grüße,
Sascha

r_kempf
Member
Beiträge: 53
Registriert: Do 14. Apr 2016, 13:27

Re: Verbindung zum Update-Server

Beitragvon r_kempf » Do 27. Apr 2017, 18:10

Eine Frage vom checkdomain-Support zum Thema WE-Update:
"Wenn ich die Verbindung zum Updateserver bei meiner Testinstallation prüfen lasse ist die Verbdinung erfolgreich. Beim Updateversuch schlägt die Verbindung allerdings fehl. Ich kann hier leider nicht feststellen, wo der Unterschied der Verbindung zu update.webedition.org beim Überprüfen und beim eigentlichen Updateversuch liegt. Müssen für das eigentliche Update noch weitere Voraussetzungen erfüllt sein?"

mokraemer
Senior Member
Beiträge: 2638
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Verbindung zum Update-Server

Beitragvon mokraemer » Do 27. Apr 2017, 19:42

also nur das du hier keinen alten Kode hast:
schau mal bei dir in der Install ob es ein Verzeichnis
webEdition/liveUpdate/updateClient
gibt, wenn ja löschen.

Der Unterschied zw. Verbindungstest und echtem Update ist, das beim Test eine Verbindung zum Server aufgebaut wird und ein Teststring gezogen wird. Beim Update selbst wird Kode gezogen, wenn der Kode nicht "ausführbar" (dekodierbar) war, kommt es zur Fehlermeldung. Wenn in WE das Fehlerlogging an ist, und es zu Problemen kommt, wird das manchmal auch im normalen Fehlerlog geloggt.
webEdition-Kern-Entwickler

r_kempf
Member
Beiträge: 53
Registriert: Do 14. Apr 2016, 13:27

Re: Verbindung zum Update-Server

Beitragvon r_kempf » Fr 28. Apr 2017, 10:26

Ich habe nachgesehen, die installierte Version WE 6.4.4 ist okay.

Im Fehlerlog steht:
file_get_contents(https://update.webedition.org/server/we ... A7fQ%3D%3D): failed to open stream: Connection refused

In den Systemeinstellungen meckert WE über die Zend Version:
Zend Framework Version 1.12.17dev

mokraemer
Senior Member
Beiträge: 2638
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Verbindung zum Update-Server

Beitragvon mokraemer » Fr 28. Apr 2017, 11:58

Zend kannst du ignorieren, das brauchen wir seit Version 6.3 nicht mehr ernsthaft.
Connection refused kommt nicht von uns - du kannst du URL ja ebenfalls lokal testen, wenn euer Server das nicht aufrufen kann, wird hier etwas vom Provider blockiert.
webEdition-Kern-Entwickler

r_kempf
Member
Beiträge: 53
Registriert: Do 14. Apr 2016, 13:27

Re: Verbindung zum Update-Server

Beitragvon r_kempf » Fr 28. Apr 2017, 16:57

Hallo Marc,
wir kommen leider nicht weiter bei der Fehlersuche. Fakt ist, WE läuft nicht bei checkdomain.de.
Gibt es eine Möglichkeit, dass Ihr bei der Fehlersuche behilflich seid, eventuell mit direkten Kontakt zum Support?
VG
Regina

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Do 8. Nov 2018, 20:34

Hi,

habe das Problem bei zweien von meinen vServern. Auf der SSH Console dauert

wget https://update.webedition.org/server/we ... A7fQ%3D%3D

ewig (2-3 Min.), bei meinen anderen nicht virtuellen Servern kommt das Ergebnis direkt. Ich vermute da muss was am Timeout eingestellt werden. Ich schau mal wann ich dazu komme und melde mich wieder.
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Do 8. Nov 2018, 20:44

... hat funktioniert. default_socket_timeout=600 und max_execution_time=600 gesetzt ;)
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Di 13. Nov 2018, 17:11

Nachtrag: Ich bin nun dazu gekommen die Updates zu machen. Allerdings sind sämtliche Seiten die den Updatevorgang betreffen (auch das PopUp wegen Hinweis auf Backup machen) extrem langsam. Im Logfile (auch auf dem Server) gibt es aber keinen Hinweis auf permante Fehler oder dergleichen. Das Update hat 25Min. gedauert.
Ansonsten ist webEdition normal schnell auf dem Server. Betrifft beide vServer. Habe auch schon unterschiedliche PHP-Varianten versucht (FPM/CGI) usw..
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

mokraemer
Senior Member
Beiträge: 2638
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Verbindung zum Update-Server

Beitragvon mokraemer » Di 13. Nov 2018, 17:41

das wird sicher irgendwie mit dieser Konfiguration zu tun haben. Irgendwas ist da auf dem vServer nicht korrekt eingestellt, das hier erst timeouts am Ende zuschlagen.
Von unserer Seite sehe ich da keine Möglichkeit etwas zu testen/machen.
Da mußt du bei deinen vServern mal schauen was hier genau passiert. Evtl. mal ein wireshark / tcpdump laufen lassen um die Ursache zu ermitteln.
webEdition-Kern-Entwickler

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Di 13. Nov 2018, 18:17

... okay. Derzeit läuft das 6 auf 7 Update seit einer Stunde. Ich lass es mal durchlaufen und schaue beim nächsten Projekt auf den Servern.
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

mokraemer
Senior Member
Beiträge: 2638
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Verbindung zum Update-Server

Beitragvon mokraemer » Di 13. Nov 2018, 20:11

autsch - das dauert normal keine 2 min
webEdition-Kern-Entwickler

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Di 13. Nov 2018, 20:27

... ich weiß. Ist aber schon bei 92% :D
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Di 13. Nov 2018, 20:40

... durchgelaufen und funktioniert sogar ;)
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied

Benutzeravatar
mausi
Senior Member
Beiträge: 380
Registriert: Di 27. Jan 2004, 16:17
Wohnort: Welver
Kontaktdaten:

Re: Verbindung zum Update-Server

Beitragvon mausi » Di 13. Nov 2018, 21:01

... schlau werde ich aus dem was mir tcpdump ausgibt nicht :oops: Vermute das der Provider eine Limitierung konfiguriert hat. Werde den Morgen mal anschreiben und lasse nun das Update auf 8.04 laufen ...
OMOC.interactive https://www.omoc.de/ - webEdition e.V. Gründungsmitglied & Fördermitglied


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste