Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Fragen zum Erstellen von Templates für webEdition.
Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Do 11. Mai 2017, 12:07

Hallo zusammen,
ich will beim Versenden von Newsletter die Email des jeweiligen Abonnenten zum Abmelden ein bisschen verschlüsseln damit wenigstens keiner direkt andere Personen einfach abmelden kann. Ich verwende dafür $GLOBALS['WE_MAIL'] um die Email auszulesen. soweit funktioniert auch alles super: /unsubscribe.html?email=<?php echo $GLOBALS['WE_MAIL']; ?>

Das Abmelden funktioniert mit der Email in Klarsicht perfekt.

Sobald ich base64_encode($GLOBALS['WE_MAIL']) verwende, wird hier immer nur '###EMAIL###' codiert ausgegeben.

Weiß da jemand weiter?
Ich weiß, dass dies kein guter Schutz ist aber es ist definitiv besser als die Email direkt anzuzeigen. Vielleicht hat auch hier jemand einen Tipp, um das Abmelden noch sicherer zu machen.

Benutzeravatar
blickfang
webEdition Partner
webEdition Partner
Beiträge: 800
Registriert: Mo 15. Dez 2003, 16:00
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon blickfang » Di 16. Mai 2017, 12:05

Hi,
Du könntest Dir vielleicht in der Kundenverwaltung (oder arbeitest Du mit einer csv?) einen hash zum USer ablegen, den Du immer mit dem Link übergibst und dann gar nicht mit der Email-Adresse arbeitest - oder in Kombination. Das Abmelden wirst Du dann aber nicht nativ über we-tags bewerkstelligen können...
webEdition Partner - https://www.blickfang-media.com
Ehemals im Vorstand des webEdition e.V.

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Mi 17. Mai 2017, 16:11

Hallo,
danke für deine Antwort. Wir arbeiten mit der Kundenverwaltung und ich will es eigentlich so einfach wie möglich machen und momentan keine zusätzliche Felder anlegen. Die we-Tags zum An- und Abmelden nutzen wir nicht, da haben wir was eigenes. Ich will eigentlich nur schnell bestehende Vorlagen anpassen und mit base64_encode($GLOBALS['WE_MAIL']) ergänzen aber es scheint nicht zu funktionieren.

$GLOBALS['WE_MAIL'] gibt die Email beim Newsletterversand korrekt aus, sobald ich encoden will mit base64_encode($GLOBALS['WE_MAIL']), wird stattdessen ###email### genommen. Ich verstehe die Logik dahinter nicht oder habe ich da einen Denkfehler?

Benutzeravatar
blickfang
webEdition Partner
webEdition Partner
Beiträge: 800
Registriert: Mo 15. Dez 2003, 16:00
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon blickfang » Mi 17. Mai 2017, 16:15

also wenn die Variable Globals den Wert ausspuckt, musst Du da auch drauf zugreifen können und mit dem Wert machen können was Du willst. Versuch mal das

Code: Alles auswählen

$email = $GLOBALS['WE_MAIL']; 
und steck dann $email an den Link ran... so richtig Sinn macht das Verhalten für mich aber ach nicht...
webEdition Partner - https://www.blickfang-media.com
Ehemals im Vorstand des webEdition e.V.

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Do 18. Mai 2017, 13:20

Hi, hab ich auch schon probiert und dann versucht $email zu encoden. Kommt trotzdem immer verschlüsselt ###email### raus. Das ist ja das merkwürdige, was ich nicht kapiere.

Benutzeravatar
blickfang
webEdition Partner
webEdition Partner
Beiträge: 800
Registriert: Mo 15. Dez 2003, 16:00
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon blickfang » Do 18. Mai 2017, 13:22

prüfts Du das beim korrekten Versand oder nur in der Vorschau? In der Vorschau steht nämlich immer ###email### drin, erst wenn das Ding korrekt als Kampagne verschickt wird, wird die Adresse je recipient gesetzt
webEdition Partner - https://www.blickfang-media.com
Ehemals im Vorstand des webEdition e.V.

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Do 18. Mai 2017, 16:50

Ich prüfe das schon direkt im erhaltenen Newsletter.

mokraemer
Senior Member
Beiträge: 3575
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon mokraemer » Do 18. Mai 2017, 19:09

Nein. Im Newsletter wird ein Template erstellt, was danach mit den Werten befüllt wird. Eine Auswertung pro NL würde viel zu viel Ressourcen kosten.
webEdition-Kern-Entwickler

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Fr 19. Mai 2017, 13:38

Hallo,
was ist damit genau gemeint? Eine Auswertung benötige ich hier nicht.
"ein. Im Newsletter wird ein Template erstellt, was danach mit den Werten befüllt wird. Eine Auswertung pro NL würde viel zu viel Ressourcen kosten.
Ich habe den Testnewsletter an mehrere Test-Emailadressen versand und zur Probe die Email mit $GLOBALS['WE_MAIL'] ausgegeben und mit base64_encode($GLOBALS['WE_MAIL']).
Bei $GLOBALS['WE_MAIL'] wird die Email immer korrekt ausgegeben, bei base64_encode($GLOBALS['WE_MAIL']) immer codiert ###EMAIL###.

Ich kann das Verhalten einfach nicht nachvollziehen. Gibt es sonst eine andere Möglichkeit auf die Email-Adresse zuzugreifen?

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Mo 12. Jun 2017, 16:42

Hi, noch einmal hoch mit dem Problem!
Weiß wirklich keiner weiter? Werde sonst ein Ticket im Bug Tracker eröffnen.

Gruß
Heiko

mokraemer
Senior Member
Beiträge: 3575
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon mokraemer » Mo 12. Jun 2017, 18:16

Du kannst dieses Feld nicht bei der NL-Generierung beeinflussen oder weiterverarbeiten. Das ist so nicht vorgesehen.
webEdition-Kern-Entwickler

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Di 13. Jun 2017, 11:43

Danke für die Antwort,
eine andere Lösung gibt es nicht? :(
Kann man nicht irgendwie separat die Email erhalten z.B. über eine Datenbankabfrage?

So kann man ja einfach andere aus dem Newsletter abmelden, vorausgesetzt man kennt die Email.

Gruß Heiko

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Di 4. Jul 2017, 13:44

Ich muss das hier noch einmal aufgreifen.

Ich habe es jetzt auch mit einer Datenbankabfrage beim Newsletterversand getestet, das funktioniert nicht.
Ein separates Feld in der Datenbank habe ich auch angelegt und versucht mit $GLOBALS drauf zuzugreifen, funktioniert auch nicht.
:cry:
Hat irgendeiner noch eine Idee? mokraemer?

Gruß
Heiko

Benutzeravatar
e-site
webEdition Partner
webEdition Partner
Beiträge: 71
Registriert: Fr 27. Mai 2016, 09:33
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon e-site » Mi 26. Jul 2017, 09:11

Hallo zusammen,
habe nun einen Feature-Wunsch im Bug Tracker angelegt. Ich hoffe, da passiert dann auch was.
Emailadressen statt einem Hashwert ausgeben ist 2017 nicht mehr ganz aktuell :shock:

Gruß
Heiko

Benutzeravatar
haydi
Senior Member
Beiträge: 627
Registriert: Do 1. Jan 1970, 02:00
Wohnort: Hirschberg
Kontaktdaten:

Re: Probleme mit Verschlüsselung der Email-Adresse im Newsletter

Beitragvon haydi » Fr 11. Nov 2022, 10:24

Zur Info... ID in der Bugbase: #11393
Heidi Wetzel
Internet-Applikationen & Webseiten-Erstellung
https://www.heidi-wetzel.de


Zurück zu „webEdition Templates erstellen (we:Tags)“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste