Update von 6.3.8.0 auf 6.4.5 Beitrag ist gelöst

Fragen und Infos zur Installation & Update von webEdition.
FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 11:05

Hallo,
das Update auf die Version 6.4.5 schlägt dauerhaft fehl.

erfüllte Systemvoraussetzungen:
- PHP Version 5.6.38-0+deb8u1
- MySQL Version 10.0.36
- max_input_vars 2000
- SSL Zertifikat ist installiert
- Datenbankbenutzer alle Optionen aktiv für Datenzugriff und Zugriff auf Struktur

Update läuft durch, danach erscheint Popup Fenster mit der Meldung
Fehler
?

Kann aus dem Forum jemand helfen? Vielen Dank bereits vorb.

Viele Grüße
André Friedrich

lukasimhof
Junior Member
Beiträge: 24
Registriert: Do 30. Aug 2012, 16:09
Wohnort: Berlin

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon lukasimhof » Mi 10. Okt 2018, 12:22

Hallo Friedrich,
kommt in der Fehlermeldung
Fehler
?

oder:
Fehler
??

Kannst du mal nachsehen, ob im Fehler-Log was drin steht dazu?
Core-Entwickler webEdition e.V.

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 12:32

Hallo,

es erschien die Meldung
Fehler
?

Danach erschien anstatt der eigentlichen internetseite diese Meldung:
no file/srv/www/vhosts/xxxxxxxx.de/httpdocs/webEdition/we/include/country/.inc.phpno file/srv/www/vhosts/xxxxxxxx.de/httpdocs/webEdition/we/include/country/.inc.php

Im Loginfenster erschienen anstatt der Symbole nur Fragezeichen.

Nach welcher Fehlermeldung soll ich suchen?

Viele Grüße
André

mokraemer
Senior Member
Beiträge: 2671
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon mokraemer » Mi 10. Okt 2018, 13:37

das klingt danach, als wäre was mit dem Sprachupdate nicht korrekt gelaufen.
Ich hab die Version nicht mehr ganz auf dem Schirm (ist ja auch schon älter). Schau mal in der Datei:
webEdition/we/include/conf/we_conf_language.inc.php

ob da irgendwo was mit _UTF8 steht. Wenn ja, das muß da weg. Da sollte nur sowas wie "de_DE" etc. stehen.
Du kannst auch die .default Datei nehmen um gültige Werte zu haben.
Da die Umstellung eigentlich mit 6.3.0 gemacht wurde, weiß ich grad nicht ob der Updater danach alle Sprachdateien gezogen hat. Also falls du es gleich auf dem Update probierst, danach eine Updatewiederholung. Im Schlimmsten Fall muß man hier mal "blind" auf den ? navigieren. Nach dem Update ist das dann aber da.
webEdition-Kern-Entwickler

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 13:43

Halo,

der Inhalt der Datei we_conf_language.inc.php sieht so aus.

<?php
$GLOBALS['weFrontendLanguages'] = array(
'de_DE',

);

$GLOBALS['weDefaultFrontendLanguage'] = 'de_DE';

Viele Grüße
André Friedrich

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 13:48

Hallo,

dei Updatewiederholung hatte ich auch schon durchgeführt. Aber ohne Erfolg. Ein Rebuild war danach nicht mehr möglich.

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 15:01

Fehlermeldung:

Error type:
User warning
Error message:
Language file "SECURITY_REPL_DOC_ROOT/webEdition/we/include/we_language/Deutsch_UTF-8/alert.inc.php" not found with entry [no_cookies]
Script name:
webEdition/we/include/we_global.inc.php
Line number:
1038
Backtrace:
#0 t_e called at [webEdition/we/include/we_global.inc.php:1038]
#1 g_l called at [webEdition/index.php:97]
#2 printHeader called at [webEdition/index.php:473]
Source code around:
webEdition/we/include/we_global.inc.php:
1037: if(!$omitErrors){
1038: t_e('Language file "' . $file . '" not found with entry ' . $specific);
1039: return '?';
1040: }
1041: return false;
1042: }

----------------------------------------------------------
webEdition/index.php:
96: if (!cookieOk) {
97: ' . we_message_reporting::getShowMessageCall(g_l('alert', '[no_cookies]'), we_message_reporting::WE_MESSAGE_ERROR) . '
98: }
99: var messageSettings = ' . (we_message_reporting::WE_MESSAGE_ERROR + we_message_reporting::WE_MESSAGE_WARNING + we_message_reporting::WE_MESSAGE_NOTICE) . ';
100:
101: /**

----------------------------------------------------------
webEdition/index.php:
472:
473: printHeader($login, (isset($httpCode) ? $httpCode : 401));
474: echo we_html_element::htmlBody(array('style' => 'background-color:#386AAB; height:100%;', "onload" => (($login == LOGIN_OK) ? "open_we();" : "document.loginForm.WE_LOGIN_username.focus();document.loginForm.WE_LOGIN_username.select();")), $_layout . ((isset($_body_javascript)) ? we_html_element::jsElement($_body_javascript) : '')) . '</html>';
475: }

----------------------------------------------------------
Request:
Server:
[USER] => krannigreifen
[HOME] => /srv/www/vhosts/rad-und-reifen.de
[FCGI_ROLE] => RESPONDER
[QS_SrvConn] => 14
[QS_IPConn] => 2
[QS_AllConn] => 14
[QS_ConnectionId] => 15391763426806612617182
[SCRIPT_URL] => /webEdition/index.php
[SCRIPT_URI] => https://www.rad-und-reifen.de/webEdition/index.php
[HTTPS] => on
[SSL_TLS_SNI] => www.rad-und-reifen.de
[proxy-nokeepalive] => 1
[HTTP_HOST] => www.rad-und-reifen.de
[HTTP_CONNECTION] => keep-alive
[HTTP_UPGRADE_INSECURE_REQUESTS] => 1
[HTTP_USER_AGENT] => Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/69.0.3497.100 Safari/537.36
[HTTP_ACCEPT] => text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8
[HTTP_REFERER] => https://www.rad-und-reifen.de/webEdition/
[HTTP_ACCEPT_ENCODING] => gzip, deflate, br
[HTTP_ACCEPT_LANGUAGE] => de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7
[HTTP_COOKIE] => cookie=yep; ; we_mode=normal; we_popup=1; wegnuvo0215uv2nk3gr7c8ld3l64=but_weTMPLDocEdit%3Dright%26but_backup_options1%3Dright; werej3g0kal3suhndc44gtdvu660=but_weTMPLDocEdit=right; PHPSESSID=gnuvo0215uv2nk3gr7c8ld3l64; WESESSION=q7suqdu8t16i0v7j4f6e6ssol6
[PATH] => /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
[SERVER_SIGNATURE] => <address>Apache Server at www.rad-und-reifen.de Port 443</address>

[SERVER_SOFTWARE] => Apache
[SERVER_NAME] => www.rad-und-reifen.de
[SERVER_ADDR] => 212.20.167.79
[SERVER_PORT] => 443
[REMOTE_ADDR] => 217.92.160.179
[DOCUMENT_ROOT] => /srv/www/vhosts/rad-und-reifen.de/httpdocs
[REQUEST_SCHEME] => https
[CONTEXT_PREFIX] =>
[CONTEXT_DOCUMENT_ROOT] => /srv/www/vhosts/rad-und-reifen.de/httpdocs
[SERVER_ADMIN] => info@aod.de
[SCRIPT_FILENAME] => /srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/index.php
[REMOTE_PORT] => 61381
[GATEWAY_INTERFACE] => CGI/1.1
[SERVER_PROTOCOL] => HTTP/1.1
[REQUEST_METHOD] => GET
[QUERY_STRING] =>
[REQUEST_URI] => /webEdition/index.php
[SCRIPT_NAME] => /webEdition/index.php
[PHP_SELF] => /webEdition/index.php
[REQUEST_TIME_FLOAT] => 1539176342.6849
[REQUEST_TIME] => 1539176342
[TMP] => /srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/we/cache
Session:
webEdition-User:
[ID] =>
[Username] =>
----------------------------------------
Internal data:

[EditPageNr] => 1
[weToolsRegistry] => Array
(
[meta] => Array
(
[0] => Array
(
[name] => toolfactory
[classname] => toolfactory
[maintable] =>
[datasource] => custom:
[startpermission] => USE_APP_TOOLFACTORY
[supportshooks] => 1
[appdisabled] => 0
[text] => Anwendungsverwaltung
)

)

[defineinclude] => Array
(
[0] => /srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/apps/toolfactory/conf/define.conf.php
)

)

----------------------------------------

[user] => Array
(
[ID] =>
[Username] =>
[workSpace] =>
[isWeSession] =>
)

Global:

mokraemer
Senior Member
Beiträge: 2671
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon mokraemer » Mi 10. Okt 2018, 15:50

2 Dinge:
1. Schau mal im Updatedialog ob da die Sprache Deutsch (ohne UTF-8) installiert ist.
2. Schau in die Einstellungen, da sollte als Backendsprache "Deutsch" ohne UTF-8 stehen!
webEdition-Kern-Entwickler

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 16:01

Hallo,

im protokoll stehen unter Meldungen diese Einträge:

0.10.2018 / 15:54 Update abgeschlossen 8.0.4.0 offizieller Release (SVN-Revision: 15901) 8.0.4.0
10.10.2018 / 15:54 Using move for installation 8.0.4.0
10.10.2018 / 15:54 8.0.4.0
10.10.2018 / 15:50 Update abgeschlossen 8.0.4.0 offizieller Release (SVN-Revision: 15901) 8.0.4.0
10.10.2018 / 15:50 Using move for installation 7.0.4.0

Als Backendsprache ist Deutsch eingetragen.

Jetzt erscheint nach dem update auf 8.04 dieser Fehler an mehreren Stellen:
no file/srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/we/include/country/.inc.phpno file/srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/we/include/country/.inc.phpno file/srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/we/include/country/.inc.phpno file/srv/www/vhosts/rad-und-reifen.de/httpdocs/webEdition/we/include/country/.inc.php

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Mi 10. Okt 2018, 17:01

Hallo,
soweit passt es jetzt.

Einzig die Fragezeichen beim Login bleibt noch. Wie bekommen wir die Loginansicht wieder in das gewohnte Bild?

Besten Dank vorab.
Dateianhänge
Screenshot_2018-10-10 www rad-und-reifen de webEdition.png
Screenshot_2018-10-10 www rad-und-reifen de webEdition.png (83.66 KiB) 375 mal betrachtet

mokraemer
Senior Member
Beiträge: 2671
Registriert: So 8. Aug 2010, 01:23
Wohnort: Mainz

Re: Update von 6.3.8.0 auf 6.4.5  Beitrag ist gelöst

Beitragvon mokraemer » Do 11. Okt 2018, 03:18

in
webEdition/we/include/conf/we_conf.inc.php
define('WE_LANGUAGE', "Deutsch");

ändern.
webEdition-Kern-Entwickler

FriedrichA
Junior Member
Beiträge: 23
Registriert: Do 11. Sep 2014, 15:55

Re: Update von 6.3.8.0 auf 6.4.5

Beitragvon FriedrichA » Do 11. Okt 2018, 08:44

Guten Morgen,

ein RIESEN Dankeschön. Jetzt funktioniert auch das wieder. TOP!

Viele Grüße
André Friedrich


Zurück zu „webEdition Installation & Update“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast